summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Iooss2019-12-16 20:34:00 +0100
committerNicolas Iooss2019-12-29 20:20:15 +0100
commit3ea1bcd2e13202036fd8644488d023db21057be2 (patch)
tree3b95d667e05b87f1c22220b8f1c03e1f53306e15 /PKGBUILD
parentf82db3692f33965acefb24f7d4d448db7d100e80 (diff)
downloadaur-3ea1bcd2e13202036fd8644488d023db21057be2.tar.gz
linux-selinux 5.4.3.arch1-1 update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 10 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a6853331661e..33e71a38c4af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,16 +7,16 @@
# If you want to help keep it up to date, please open a Pull Request there.
pkgbase=linux-selinux
-pkgver=5.3.12.1
+pkgver=5.4.3.arch1
pkgrel=1
pkgdesc='Linux SELinux'
-_srctag=v${pkgver%.*}-arch${pkgver##*.}
+_srctag=v${pkgver%.*}-${pkgver##*.}
url="https://git.archlinux.org/linux.git/log/?h=$_srctag"
arch=(x86_64)
license=(GPL2)
makedepends=(
- xmlto kmod inetutils bc libelf
- python-sphinx python-sphinx_rtd_theme graphviz imagemagick
+ bc kmod libelf
+ xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick
git
)
options=('!strip')
@@ -36,7 +36,7 @@ validpgpkeys=(
'8218F88849AAC522E94CF470A5E9288C4FA415FA' # Jan Alexander Steffens (heftig)
)
sha256sums=('SKIP'
- '10ee7800902b1d82f9c184b367c9d904f4dc48f6d9ce3277327e825d7ab690d1')
+ '5d58a2115892839997ae7dcca226697c34b656de7685cb3eb8696451dc5100a0')
export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
@@ -65,9 +65,6 @@ prepare() {
make -s kernelrelease > version
msg2 "Prepared %s version %s" "$pkgbase" "$(<version)"
-
- # save configuration for later reuse
- cat .config > "${startdir}/config.last"
}
build() {
@@ -182,26 +179,18 @@ _package-headers() {
}
_package-docs() {
- pkgdesc="Kernel hacker's manual for the $pkgdesc kernel"
+ pkgdesc="Documentation for the $pkgdesc kernel"
cd $_srcname
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
msg2 "Installing documentation..."
- mkdir -p "$builddir"
- cp -t "$builddir" -a Documentation
-
- msg2 "Removing unneeded files..."
- rm -rv "$builddir"/Documentation/{,output/}.[^.]*
-
- msg2 "Moving HTML docs..."
local src dst
while read -rd '' src; do
- dst="$builddir/Documentation/${src#$builddir/Documentation/output/}"
- mkdir -p "${dst%/*}"
- mv "$src" "$dst"
- rmdir -p --ignore-fail-on-non-empty "${src%/*}"
- done < <(find "$builddir/Documentation/output" -type f -print0)
+ dst="${src#Documentation/}"
+ dst="$builddir/Documentation/${dst#output/}"
+ install -Dm644 "$src" "$dst"
+ done < <(find Documentation -name '.*' -prune -o ! -type d -print0)
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/share/doc"