summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Iooss2014-10-24 13:36:03 +0200
committerNicolas Iooss2015-06-27 11:44:57 +0800
commit4b3b3021618fa455563512be3c8ee3cd6b9cd08d (patch)
treeec5a22dbb318cf70fe5d12174bd3dd6f5b0709db /PKGBUILD
parent1030747539dff606ec089bcf882536658d2ef6f1 (diff)
downloadaur-4b3b3021618fa455563512be3c8ee3cd6b9cd08d.tar.gz
linux-selinux 3.17.1-1 update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 9 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aff36b934539..fc8cb9cc3adc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# SELinux Maintainer: Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
pkgbase=linux-selinux
-_srcname=linux-3.16
-pkgver=3.16.4
+_srcname=linux-3.17
+pkgver=3.17.1
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
@@ -20,15 +20,13 @@ source=("https://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
# standard config files for mkinitcpio ramdisk
'linux-selinux.preset'
'change-default-console-loglevel.patch'
- 'compal-laptop-hwmon-fix.patch'
)
-sha256sums=('4813ad7927a7d92e5339a873ab16201b242b2748934f12cb5df9ba2cfe1d77a0'
- 'bfd65be726f596c0e46f472efa33c46c01be5d44ed93ef645c313a6823e6e6fb'
- '19f703141aacbd61ed3b913b24dee794950b2978e0b2d60c3f4a717e45922f4e'
- 'c1841e14ff98ff63052949ab97331d535180e94db7c5bc94e2d8154e286e5b6a'
+sha256sums=('f5153ec93c5fcd41b247950e6a9bcbc63fa87beafd112c133a622439a0f76251'
+ '3b0651951cdc0a81a69b46db99239bc9f00d6a5ae403e0e41c7a1cc177544ec2'
+ '1331d1b35309c8905ab53c82204580bd7c74d5aac11c8e29fe27e6c4b50399e0'
+ '0dd66b478fcaa8f0ce88debf4681443b82336445af2215b87f186ac8f2a9ff48'
'375da3b030f17581cbf5be9140b79029ca85eebc70197f419a4de77e00fa84e9'
- '1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
- 'f36f61a0a72bcb0a9c04264343503bfbf927c9ea0db819e66734a3933b060588')
+ '1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99')
_kernelname=${pkgbase#linux}
@@ -46,9 +44,6 @@ prepare() {
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
patch -p1 -i "${srcdir}/change-default-console-loglevel.patch"
- # #41458 fix hwmon for compal-laptop module
- patch -p1 -i "${srcdir}/compal-laptop-hwmon-fix.patch"
-
if [ "${CARCH}" = "x86_64" ]; then
cat "${srcdir}/config.x86_64" > ./.config
else
@@ -250,7 +245,8 @@ _package-headers() {
# add xfs and shmem for aufs building
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/fs/xfs"
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/mm"
- cp fs/xfs/xfs_sb.h "${pkgdir}/usr/lib/modules/${_kernver}/build/fs/xfs/xfs_sb.h"
+ # removed in 3.17 series
+ # cp fs/xfs/xfs_sb.h "${pkgdir}/usr/lib/modules/${_kernver}/build/fs/xfs/xfs_sb.h"
# copy in Kconfig files
for i in $(find . -name "Kconfig*"); do