summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Iooss2014-05-04 10:58:59 +0200
committerNicolas Iooss2015-06-27 11:44:55 +0800
commita21c1f7ef2afc7686a9920c80638091841ea9294 (patch)
tree78892b58e5c7d23184611b6fc5c1a2b0f612b9dc /PKGBUILD
parentc3124f0402644749c675113f677654b4496cf5cf (diff)
downloadaur-a21c1f7ef2afc7686a9920c80638091841ea9294.tar.gz
linux 3.14.2-1 update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 39 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index efb0a8ff3cf3..7cb422377230 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgbase=linux-selinux # Build stock -ARCH kernel
#pkgbase=linux-custom # Build kernel with a different name
_srcname=linux-3.14
-pkgver=3.14.1
+pkgver=3.14.2
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
@@ -28,14 +28,17 @@ source=("https://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
'0005-Revert-Bluetooth-Enable-autosuspend-for-Intel-Blueto.patch'
'0006-genksyms-fix-typeof-handling.patch'
'0007-x86-efi-Correct-EFI-boot-stub-use-of-code32_start.patch'
- '0008-futex-avoid-race-between-requeue-and-wake.patch'
- '0009-iwlwifi-mvm-rs-fix-search-cycle-rules.patch'
'0010-iwlwifi-mvm-delay-enabling-smart-FIFO-until-after-be.patch'
+ '0011-kernfs-fix-removed-error-check.patch'
+ '0012-fix-saa7134.patch'
+ '0013-net-Start-with-correct-mac_len-in-skb_network_protocol.patch'
+ '0014-fix-rtl8192se.patch'
+ '0015-fix-xsdt-validation.patch'
)
sha256sums=('61558aa490855f42b6340d1a1596be47454909629327c49a5e4e10268065dffa'
- 'ac56f0bff3c6ec436161f2702c7269b933e22bae0488ed709ab29e4aeb78be45'
- '4c1bacbafea62ca9db8207f1deebab3973acf6a7a1b327327f49733f7fc699da'
- 'd13e8d4d85b1211ae85df42b8b1fc79ab006516c2e8de52dc9d50ff77559525f'
+ '1c7a8fee1674bfa6354dc6e3038ca1f16bc1327b035cd4896b795b482c7d1829'
+ 'db62a32d53b424cf6ac353e9b0defba285232ee2bc73a2bd50518240cf07e5d6'
+ 'b12dbc3e0ce057a3f68a129b6c97fe29f62adca8c1fcc82166968278214e4091'
'375da3b030f17581cbf5be9140b79029ca85eebc70197f419a4de77e00fa84e9'
'faced4eb4c47c4eb1a9ee8a5bf8a7c4b49d6b4d78efbe426e410730e6267d182'
'6d72e14552df59e6310f16c176806c408355951724cd5b48a47bf01591b8be02'
@@ -45,9 +48,12 @@ sha256sums=('61558aa490855f42b6340d1a1596be47454909629327c49a5e4e10268065dffa'
'3fffb01cf97a5a7ab9601cb277d2468c0fb1e1cceba4225915f3ffae3a5694ec'
'cf2e7a2d00787f754028e7459688c2755a406e632ce48b60952fa4ff7ed6f4b7'
'a98bc3836bcf85774a974a1585e6b64432ba8c42363ee484d14515ccd6a88e24'
- 'f8699fcf4242c0727c3c0af56928515cef9b6ce329968537ce2894b30d43eade'
- '1d4c7b24312ed3781e5d139dfb52f0c22350bf5a2845fe747469dfa7b6ed861f'
- 'c0af4622f75c89fef62183e18b7d49998228d4eaa906c6accaf4aa4ff0134f85')
+ 'c0af4622f75c89fef62183e18b7d49998228d4eaa906c6accaf4aa4ff0134f85'
+ '04f44bf5c181d6dc31905937c1bdccb0f5aecaad3a579e99b302502b9cbe0f7a'
+ '79359454c9d8446eb55add2b1cdbf8332bd67dafb01fefb5b1ca090225f64d18'
+ 'f2a5e22c1ba6e9b8a32a7bd4a5327ee95538aa10edcee3cd12578f8ff49bf6be'
+ 'ff9df6746d7cbfe858d5b4bce932951c26414a7635cb5c26cd8d5c97df36a2a1'
+ '384dd13fd4248fd6809da8c6ae29ced55d4a5cacc33ac2ae7522093ec0fb26d4')
_kernelname=${pkgbase#linux}
@@ -93,6 +99,30 @@ prepare() {
# https://git.kernel.org/cgit/linux/kernel/git/iwlwifi/iwlwifi-fixes.git/commit/?id=12f853a89e29f50b17698e17e73c328a35f1498d
# FS#39815
patch -p1 -i "${srcdir}/0010-iwlwifi-mvm-delay-enabling-smart-FIFO-until-after-be.patch"
+
+ # fix Xorg crash with i810 chipset due to wrong removed error check
+ # References: http://lkml.kernel.org/g/533D01BD.1010200@googlemail.com
+ patch -Np1 -i "${srcdir}/0011-kernfs-fix-removed-error-check.patch"
+
+ # fix saa7134 video
+ # https://bugs.archlinux.org/task/39904
+ # https://bugzilla.kernel.org/show_bug.cgi?id=73361
+ patch -Np1 -i "${srcdir}/0012-fix-saa7134.patch"
+
+ # fix tun/openvpn performance
+ # https://bugs.archlinux.org/task/40089
+ # https://bugzilla.kernel.org/show_bug.cgi?id=74051
+ patch -Np1 -i "${srcdir}/0013-net-Start-with-correct-mac_len-in-skb_network_protocol.patch"
+
+ # fix rtl8192se authentification
+ # https://bugs.archlinux.org/task/39858
+ # https://bugzilla.kernel.org/show_bug.cgi?id=74541
+ patch -Np1 -i "${srcdir}/0014-fix-rtl8192se.patch"
+
+ # fix xsdt validation bug
+ # https://bugs.archlinux.org/task/39811
+ # https://bugzilla.kernel.org/show_bug.cgi?id=73911
+ patch -Np1 -i "${srcdir}/0015-fix-xsdt-validation.patch"
if [ "${CARCH}" = "x86_64" ]; then
cat "${srcdir}/config.x86_64" > ./.config