summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Iooss2018-12-16 17:47:28 +0100
committerNicolas Iooss2018-12-16 17:47:28 +0100
commitccbf6fc95f1f5c8040c411747f1ae7f76f571056 (patch)
tree29f0b8161566a61023906d9fa281a29e34ebc2ac /PKGBUILD
parent69402ce99f1916632a1402e03939a01c28498562 (diff)
downloadaur-ccbf6fc95f1f5c8040c411747f1ae7f76f571056.tar.gz
linux-selinux 4.19.8.arch1-1 update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8ff3a1509d94..8c0648876c9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# If you want to help keep it up to date, please open a Pull Request there.
pkgbase=linux-selinux
-_srcver=4.19.4-arch1
+_srcver=4.19.8-arch1
pkgver=${_srcver//-/.}
pkgrel=1
arch=(x86_64)
@@ -34,9 +34,9 @@ validpgpkeys=(
'8218F88849AAC522E94CF470A5E9288C4FA415FA' # Jan Alexander Steffens (heftig)
)
sha256sums=('SKIP'
- '46ad4e1653df351769908b75db7e297a422a332d9fba8045ab9d0843807a01a2'
+ 'e8f4f68a8a21f82879e4069fda76a796e860d60a71c9db4e45fb93d58734a03f'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
- '75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
+ 'c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65')
_kernelname=${pkgbase#linux}
@@ -84,22 +84,19 @@ _package() {
install=linux.install
local kernver="$(<version)"
+ local modulesdir="$pkgdir/usr/lib/modules/$kernver"
cd $_srcname
msg2 "Installing boot image..."
- local image="$pkgdir/boot/vmlinuz-$pkgbase"
- install -Dm644 "$(make -s image_name)" "$image"
+ # systemd expects to find the kernel here to allow hibernation
+ # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
+ install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
+ install -Dm644 "$modulesdir/vmlinuz" "$pkgdir/boot/vmlinuz-$pkgbase"
msg2 "Installing modules..."
- local modulesdir="$pkgdir/usr/lib/modules/$kernver"
- mkdir -p "$modulesdir"
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
- # systemd expects to find the kernel here to allow hibernation
- # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
- ln -sr "$image" "$modulesdir/vmlinuz"
-
# a place for external modules,
# with version file for building modules and running depmod from hook
local extramodules="extramodules$_kernelname"