summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuca Weiss2016-07-19 14:52:55 +0200
committerLuca Weiss2016-07-19 14:52:55 +0200
commitc481f63d647250329c9eb8d6fb78119215a0425b (patch)
treeffc34382ab04d5443eb3c8bb49bba64790d7f5a5 /PKGBUILD
downloadaur-c481f63d647250329c9eb8d6fb78119215a0425b.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6435e0669c7e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Luca Weiss <WEI16416@spengergasse.at>
+
+pkgname=linux-steam-integration
+pkgver=0.2
+pkgrel=1
+pkgdesc="Helper for enabling better Steam integration on Linux"
+url="https://github.com/solus-project/linux-steam-integration"
+arch=('x86_64' 'i686')
+license=('LGPL2.1')
+depends=('gtk3')
+# makedepends=('')
+#provides=("steam") ? I don't know what I should do because this wants to move the normal steam binary...
+#conflicts=("steam")
+source=("https://github.com/solus-project/linux-steam-integration/releases/download/v${pkgver}/linux-steam-integration-${pkgver}.tar.xz")
+md5sums=('bde97f0ee9995baa7f3bd2750b93198e')
+
+prepare() {
+ cd $srcdir/$pkgname-$pkgver
+# ./autogen.sh --enable-frontend --prefix=$pkgdir (for the -git version)
+ args="\
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --prefix=/usr \
+ --enable-frontend \
+ --enable-silent-rules"
+ ./configure CFLAGS="-g -O1 $CFLAGS" $args "$@"
+}
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et:
+