summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoralyptik2016-11-03 20:20:42 -1000
committeralyptik2016-11-03 20:22:39 -1000
commit34a45299d21434e9c986524a7993b0b1c9b0f911 (patch)
treeb0bdd07dbf603dd442ffec10b082b7424b0a8ded /PKGBUILD
parentccddc0daffa098aa6bcdc1ed20c7aa0ce15fe04f (diff)
downloadaur-34a45299d21434e9c986524a7993b0b1c9b0f911.tar.gz
Updated to linux-4.8.6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD56
1 files changed, 31 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f1969ef33085..eed32e35a220 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
# Contributor: Matthew Wardrop <mister.wardrop@gmail.com>
pkgbase=linux-surfacepro3-rt
-_srcname=linux-4.8.2
-pkgver=4.8.2
-pkgrel=1.7
+_srcname=linux-4.8.6
+pkgver=4.8.6
+pkgrel=1.8
arch=('i686' 'x86_64')
url="https://github.com/alyptik/linux-surfacepro3-rt"
license=('GPL2')
@@ -12,15 +12,14 @@ makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'elfutils')
options=('!strip')
source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.sign"
- "https://www.kernel.org/pub/linux/kernel/projects/rt/${pkgver%.*}/older/patch-${pkgver}-rt2.patch.xz"
- "https://www.kernel.org/pub/linux/kernel/projects/rt/${pkgver%.*}/older/patch-${pkgver}-rt2.patch.sign"
+ "https://www.kernel.org/pub/linux/kernel/projects/rt/${pkgver%.*}/older/patch-${pkgver}-rt5.patch.xz"
+ "https://www.kernel.org/pub/linux/kernel/projects/rt/${pkgver%.*}/older/patch-${pkgver}-rt5.patch.sign"
# Brain Fuck Scheduler & other personal patches
'https://raw.githubusercontent.com/alyptik/linux-surfacepro3-rt/github/bfq.patch'
'https://raw.githubusercontent.com/alyptik/linux-surfacepro3-rt/github/bfs.patch'
'https://raw.githubusercontent.com/alyptik/linux-surfacepro3-rt/github/bfs-fixes1.patch'
'https://raw.githubusercontent.com/alyptik/linux-surfacepro3-rt/github/bfs-fixes2.patch'
'https://raw.githubusercontent.com/alyptik/linux-surfacepro3-rt/github/block.patch'
- 'https://raw.githubusercontent.com/alyptik/linux-surfacepro3-rt/github/btrfs.patch'
'https://raw.githubusercontent.com/alyptik/linux-surfacepro3-rt/github/init.patch'
'https://raw.githubusercontent.com/alyptik/linux-surfacepro3-rt/github/kconfig.patch'
'https://raw.githubusercontent.com/alyptik/linux-surfacepro3-rt/github/xattr.patch'
@@ -36,16 +35,15 @@ source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'change-default-console-loglevel.patch'
)
-sha256sums=('983636c755a397a1075001cd99fad8b85485bebf15e62ed56f3ca3ba5e225d03'
+sha256sums=('74744e00420856cfc8049fa3b3a55e57a116994226a498ef56801bc9492df36b'
'SKIP'
- '559f4f1fa49a7a362cd26bccad609f3f25c7c5be58f7d6404c73aa05349bb362'
+ 'f0e1bc55ec0288e54e84cc35a9e16a9df93be3772fda58b654ece6260f12699a'
'SKIP'
'48afded166076dc357bfb68640297e0337c70d6f72e05e1eb040e694de0ad7ed'
'51f91681b708149fe91e565f5c40811477428e2aa86f8726a20e0e7c55c5407c'
'cec65d71766429be99bdc9da7897584fdc4bf4df3a4b26d228ff55a76ea3d8ea'
'48d0d2e549ceddc18a59cc5f0d9325db5727ac82a9a4829c99a781ce979e1a6d'
'ba5c7ee929108ac05800d7c8a7a28c28b2e04679ad33089ea53af15a955d5c5e'
- '95bbb2b4c84c1faf5ebbe229a9d458a1c37524175ba71f07adc6fc4dbf09a80e'
'ec655100ebc32d6699a258d7682953f928d1eb1042b895b04283d85ae57b80c1'
'f479a5ca6abe4d50ca4c09e6e83a027369fcd3efff8d5ce60f0699d8fa47beb8'
'4633ae19b9a9871a3cfffba98ec7c3cd240f64bef8a0eebcf1212219c80972fd'
@@ -56,7 +54,7 @@ sha256sums=('983636c755a397a1075001cd99fad8b85485bebf15e62ed56f3ca3ba5e225d03'
'52e7c895aeb505bc8d3b5321a346fcdbb749f8035cacc97a237c24c1f527adbc'
'0fcd0b22fe9ec58ba41b81b463f68d619b6898a5c405fb26c85237a183240371'
'577a3c4c211e6946fb8c1448d6a325861b41c8c8660203ae7d63a58f3af0d279'
- '921f64223b44c51e762625a9d338fca9e728397e3d58415f322c90a9f15371ec'
+ '293ac0c17f8addc6f259cfe7f89ff13d3fa64f4f5588f944bf43a2c8b2fdc4ef'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99')
@@ -69,32 +67,33 @@ validpgpkeys=(
multitouch='y'
sp3config='y'
bcache='n'
+bfs='n'
+bfq='n'
+personal='y'
_kernelname=${pkgbase#linux}
prepare() {
cd "${srcdir}/${_srcname}"
- ## BFS/BFQ patches not working currently
- #for i in bfq.patch bfs.patch bfs-fixes1.patch bfs-fixes2.patch; do
- # patch -p1 -i "${srcdir}/${i}"
- #done
-
- ## Add personal patches
- for i in block.patch btrfs.patch init.patch kconfig.patch xattr.patch xfs.patch; do
- patch -p1 -i "${srcdir}/${i}"
- done
-
- ## Enable unsupported bcache module
+ ## BFS/BFQ patches and unsupported BCache module; none of these worked during current testing
+ if [ "$bfq" != 'n' ]; then patch -p1 -i "${srcdir}/bfq.patch"; fi
+ if [ "$bfs" != 'n' ]; then
+ for i in bfq.patch bfs.patch bfs-fixes1.patch bfs-fixes2.patch; do patch -p1 -i "${srcdir}/${i}"; done
+ fi
if [ "$bcache" != 'n' ]; then
sed -i '\%^diff --git a/drivers/md/bcache/Kconfig b/drivers/md/bcache/Kconfig$%,+11 d' "${srcdir}/patch-${pkgver}-rt2.patch"
cp "${srcdir}/linux-${pkgver}/include/linux/rwsem.h" "${srcdir}/linux-${pkgver}/drivers/md/bcache/"
sed -i '/#include "bcache.h"/i #include "rwsem.h"\n' "${srcdir}/linux-${pkgver}/drivers/md/bcache/request.c"
fi
+ ## Add personal patches
+ if [ "$personal" != 'n' ]; then
+ for i in block.patch init.patch kconfig.patch xattr.patch xfs.patch; do patch -p1 -i "${srcdir}/${i}"; done
+ fi
+
# Add RT patches
- patch -p1 -i "${srcdir}/patch-${pkgver}-rt2.patch"
- #xzcat "${srcdir}/patch-${pkgver}-rt1.patch.xz" | patch -p1 -F3
+ patch -p1 -i "${srcdir}/patch-${pkgver}-rt5.patch"
# add upstream patch
#patch -p1 -i "${srcdir}/patch-${pkgver}"
@@ -123,7 +122,7 @@ prepare() {
if [ "${CARCH}" = "x86_64" ]; then
## Set sp3config='y' to use the personal config as a base
- [[ "$sp3config" != 'n' ]] && cat "${srcdir}/config.sp3" >./.config || cat "${srcdir}/config.x86_64" >./.config
+ [ "$sp3config" != 'n' ] && cat "${srcdir}/config.sp3.final" >./.config || cat "${srcdir}/config.x86_64" >./.config
else
cat "${srcdir}/config" > ./.config
fi
@@ -150,10 +149,17 @@ prepare() {
printf '\n \033[32m %s \033[0m ' "[Run interactive nconfig? (Y/n)]"; read -r; echo
case $REPLY in
[Yy]*|'') make nconfig ;; # new CLI menu for configuration
- [Nn]*) printf ' \033[31m %s \n\033[0m ' "Continuing..."; make olddefconfig ;;
+ [Nn]*) printf ' \033[32m %s \n\033[0m ' "Continuing..."; make olddefconfig ;;
*) printf ' \033[31m %s \n\033[0m ' "Invalid input..."; return 1 ;;
esac
+ printf '\n \033[32m %s \033[0m ' "[Run local(mod|yes)config? (M/y)]"; read -r; echo
+ case $REPLY in
+ [Mm]*|'') make localmodconfig ;;
+ [Yy]*) make localyesconfig ;;
+ *) printf ' \033[32m %s \n\033[0m ' "Continuing..." ;;
+ esac
+
# get kernel version
make prepare