summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2021-03-10 21:07:09 +0100
committerFabioLolix2021-03-10 21:07:09 +0100
commit02867e6b23eed3c6b7301a61bb6876c68c4f3ab9 (patch)
tree4938deb07a180443ea32a3fbde68905b35157442 /PKGBUILD
parent55672c24ab93e845efb7c181c2d5fde47bf16812 (diff)
downloadaur-02867e6b23eed3c6b7301a61bb6876c68c4f3ab9.tar.gz
v20210121
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD34
1 files changed, 13 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f35c34954718..fd1db4e10427 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,25 @@
-# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
# Contributor: Lukas Jirkovsky <l.jirkovsky@gmail.com>
pkgname=linux-test-project
-pkgver=20180515
+pkgver=20210121
pkgrel=1
-pkgdesc="A collection of tools for testing the Linux kernel and related features"
-arch=('i686' 'x86_64')
-license=('GPL2')
-url="http://linux-test-project.github.io/"
-depends=('acl' 'bash' 'gawk' 'libcap' 'libtirpc' 'python2' 'libaio' 'numactl')
-source=("https://github.com/linux-test-project/ltp/releases/download/$pkgver/ltp-full-$pkgver.tar.bz2")
-md5sums=('e104b70ae4b0d7f7e728ef5345242d2c')
-
-prepare() {
- cd "$srcdir/ltp-full-$pkgver"
-
- find . -type f -exec sed -i 's|^#!.*python$|#!/usr/bin/env python2|' '{}' ';'
- ./configure --mandir=/usr/share/man --with-bash
-}
+pkgdesc="Collection of tools for testing the Linux kernel and related features"
+arch=(i686 x86_64)
+license=(GPL2)
+url="https://linux-test-project.github.io/"
+depends=(acl bash gawk libcap libtirpc python numactl)
+source=("https://github.com/linux-test-project/ltp/releases/download/${pkgver}/ltp-full-${pkgver}.tar.xz")
+sha256sums=('72b0a063f0d48efaaa93ed403d56662ac2b1dd3f74ecb5c6e5b3900791fa6c29')
build() {
- cd "$srcdir/ltp-full-$pkgver"
-
- make all
+ cd "${srcdir}/ltp-full-${pkgver}"
+ ./configure --prefix=/usr/share --mandir=/usr/share/man --with-bash
+ make
}
package() {
- cd "$srcdir/ltp-full-$pkgver"
-
+ cd "${srcdir}/ltp-full-${pkgver}"
make DESTDIR="$pkgdir" install
}