summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordysphoria2015-10-13 15:17:53 +0100
committerdysphoria2015-10-13 15:17:53 +0100
commit4ce2d62c03afcc23c13fd033b2cc00479343f7d6 (patch)
tree02fed5fd9fe5e1aa69c5ae3ab5ac5e56668a211d /PKGBUILD
parent90b508c43b30232b67dac36335504b7625b37a91 (diff)
downloadaur-4ce2d62c03afcc23c13fd033b2cc00479343f7d6.tar.gz
[upd] Bump to 4.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD65
1 files changed, 36 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 35c6876f4899..795d1ab45b4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,19 @@
-# AUR/linux-tomoyo PKGBUILD
-# Maintainer: dysphr <>
+# AUR/linux-lts-tomoyo PKGBUILD
+# Maintainer: dysphoria <>
#
-# arch/linux PKGBUILD
+# core/linux-lts PKGBUILD 247257 2015-10-01 14:40:57Z tpowa $
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: Thomas Baechler <thomas@archlinux.org>
-#pkgbase=linux # Build stock -ARCH kernel
-pkgbase=linux-tomoyo # Build kernel with a different name
-_srcname=linux-4.1
-pkgver=4.1.6
+pkgbase=linux-tomoyo
+_srcname=linux-4.2
+pkgver=4.2.2
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc')
-provides=('linux')
options=('!strip')
-provides=('linux')
source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.sign"
"https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
@@ -25,15 +22,21 @@ source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'config' 'config.x86_64'
# standard config files for mkinitcpio ramdisk
'linux-tomoyo.preset'
- 'change-default-console-loglevel.patch')
-sha256sums=('caf51f085aac1e1cea4d00dbbf3093ead07b551fc07b31b2a989c05f8ea72d9f'
+ 'change-default-console-loglevel.patch'
+ '0001-e1000e-Fix-tight-loop-implementation-of-systime-read.patch'
+ '0001-netfilter-conntrack-use-nf_ct_tmpl_free-in-CT-synpro.patch'
+ '0001-fix-bridge-regression.patch')
+sha256sums=('cf20e044f17588d2a42c8f2a450b0fd84dfdbd579b489d93e9ab7d0e8b45dbeb'
'SKIP'
- '64e4deb16a279e233b0c91463b131bd0f3de6aabdb49efded8314bcf5dbfe070'
+ '8b4578f1e1dcfbef1e39c39b861d4715aa99917af0b7c2dc324622d65884dcb5'
'SKIP'
- 'f4c6a5c2fc0ee2b792e43f4c1846b995051901a502fb97885d2296af55fa193d'
- '58d49d4a3f6152394d903fd09113116fa3a0939d7d7ee419b2edbbd0c30e1755'
- '4f42b2fb6ff7e21e5b7c2b1031da2fb732016932c59ebc6308c135f9ea9fd6a8'
- '1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99')
+ 'e6f6f804f98ad321ce3e4395924993b51decb89699fde369391ccbb4bae928b2'
+ 'a071aaa327d2b3577fa4709b47ed5fe81c7914d168607f3db905fdbf226247e7'
+ 'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
+ '1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
+ '0b1e41ba59ae45f5929963aa22fdc53bc8ffb4534e976cec046269d1a462197b'
+ '6ed9e31ae5614c289c4884620e45698e764c03670ebc45bab9319d741238cbd3'
+ '0a8fe4434e930d393c7983e335842f6cb77ee263af5592a0ca7e14bae7296183')
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
@@ -50,6 +53,19 @@ prepare() {
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
+ # fix hard lockup in e1000e_cyclecounter_read() after 4 hours of uptime
+ # https://lkml.org/lkml/2015/8/18/292
+ patch -p1 -i "${srcdir}/0001-e1000e-Fix-tight-loop-implementation-of-systime-read.patch"
+
+ # add not-yet-mainlined patch to fix network unavailability when iptables
+ # rules are applied during startup - happened with Shorewall; journal had
+ # many instances of this error: nf_conntrack: table full, dropping packet
+ patch -p1 -i "${srcdir}/0001-netfilter-conntrack-use-nf_ct_tmpl_free-in-CT-synpro.patch"
+
+ # add not-yes-mainlined patch to fix bridge code
+ # https://bugzilla.kernel.org/show_bug.cgi?id=104161
+ patch -Np1 -i "${srcdir}/0001-fix-bridge-regression.patch"
+
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
@@ -63,9 +79,9 @@ prepare() {
# Enable TOMOYO Linux
msg "Enabling TOMOYO Linux..."
- sed -i -e 's:# CONFIG_SECURITY_TOMOYO is not set:CONFIG_SECURITY_TOMOYO=y\nCONFIG_SECURITY_TOMOYO_MAX_ACCEPT_ENTRY=2048\nCONFIG_SECURITY_TOMYO_MAX_AUDIT_LOG=1024\n# CONFIG_SECURITY_TOMOYO_OMIT_USERSPACE_LOADER is not set\nCONFIG_SECURITY_TOMOYO_POLICY_LOADER="/sbin/tomoyo-init"\nCONFIG_SECURITY_TOMOYO_ACTIVATION_TRIGGER="/sbin/init":' \
- -i -e 's/CONFIG_DEFAULT_SECURITY_DAC=y/# CONFIG_DEFAULT_DAC is not set/' \
- -i -e '/CONFIG_DEFAULT_SECURITY/ s,"","tomoyo",' ./.config
+ sed -i -e 's,# CONFIG_SECURITY_TOMOYO is not set,CONFIG_SECURITY_TOMOYO=y\nCONFIG_SECURITY_TOMOYO_MAX_ACCEPT_ENTRY=2048\nCONFIG_SECURITY_TOMYO_MAX_AUDIT_LOG=1024\n# CONFIG_SECURITY_TOMOYO_OMIT_USERSPACE_LOADER is not set\nCONFIG_SECURITY_TOMOYO_POLICY_LOADER="/sbin/tomoyo-init"\nCONFIG_SECURITY_TOMOYO_ACTIVATION_TRIGGER="/usr/lib/systemd/systemd",' \
+ -i -e 's/CONFIG_DEFAULT_SECURITY_DAC=y/# CONFIG_DEFAULT_SECURITY_DAC is not set/' \
+ -i -e '/CONFIG_DEFAULT_SECURITY=/ s,"","tomoyo",' ./.config
if [ "${_kernelname}" != "" ]; then
sed -i "s|CONFIG_LOCALVERSION=.*|CONFIG_LOCALVERSION=\"${_kernelname}\"|g" ./.config
@@ -104,9 +120,6 @@ _package() {
[ "${pkgbase}" = "linux" ] && groups=('base')
depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=0.7')
optdepends=('crda: to set the correct wireless channels of your country')
- provides=("kernel26${_kernelname}=${pkgver}")
- conflicts=("kernel26${_kernelname}")
- replaces=("kernel26${_kernelname}")
backup=("etc/mkinitcpio.d/${pkgbase}.preset")
install=linux-tomoyo.install
@@ -132,7 +145,7 @@ _package() {
-i "${startdir}/${install}"
# install mkinitcpio preset file for kernel
- install -D -m644 "${srcdir}/linux-tomoyo.preset" "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
+ install -D -m644 "${srcdir}/linux.preset" "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
sed \
-e "1s|'linux.*'|'${pkgbase}'|" \
-e "s|ALL_kver=.*|ALL_kver=\"/boot/vmlinuz-${pkgbase}\"|" \
@@ -163,9 +176,6 @@ _package() {
_package-headers() {
pkgdesc="Header files and scripts for building modules for ${pkgbase/linux/Linux} kernel"
- provides=("kernel26${_kernelname}-headers=${pkgver}")
- conflicts=("kernel26${_kernelname}-headers")
- replaces=("kernel26${_kernelname}-headers")
install -dm755 "${pkgdir}/usr/lib/modules/${_kernver}"
@@ -283,9 +293,6 @@ _package-headers() {
_package-docs() {
pkgdesc="Kernel hackers manual - HTML documentation that comes with the ${pkgbase/linux/Linux} kernel"
- provides=("kernel26${_kernelname}-docs=${pkgver}")
- conflicts=("kernel26${_kernelname}-docs")
- replaces=("kernel26${_kernelname}-docs")
cd "${srcdir}/${_srcname}"