summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordysphoria2016-04-20 23:42:18 +0100
committerdysphoria2016-04-20 23:42:18 +0100
commit80863143dab5ee9fa52542f1f0b084f8af81b5c2 (patch)
tree4206e76117ae7c358c402d3b31a55bda4b761337 /PKGBUILD
parentce890b9210e90745199e97e590dfe62ebfdf26d4 (diff)
downloadaur-80863143dab5ee9fa52542f1f0b084f8af81b5c2.tar.gz
[upd] bump to 4.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 11 insertions, 31 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 542266408874..db7b7cf3f7b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# AUR/linux-tomoyo PKGBUILD
# Maintainer: dysphoria <>
-# core/linux PKGBUILD 2016-02-03
+# core/linux PKGBUILD 2016-04-20 $Id: PKGBUILD 265148 2016-04-19 06:55:26Z tpowa $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
pkgbase=linux-tomoyo
-_srcname=linux-4.4
-pkgver=4.4.1
+_srcname=linux-4.5
+pkgver=4.5.1
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc')
options=('!strip')
+provides=('linux')
source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.sign"
"https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
@@ -22,24 +23,16 @@ source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'config' 'config.x86_64'
# standard config files for mkinitcpio ramdisk
'linux-tomoyo.preset'
- 'change-default-console-loglevel.patch'
- '0001-sdhci-revert.patch'
- 'tpmdd-devel-v3-base-platform-fix-binding-for-drivers-without-probe-callback.patch'
- '0001-4.4-revert-btrfs.patch'
- '0001-4.4-revert-xfs.patch')
+ 'change-default-console-loglevel.patch')
-sha256sums=('401d7c8fef594999a460d10c72c5a94e9c2e1022f16795ec51746b0d165418b2'
+sha256sums=('a40defb401e01b37d6b8c8ad5c1bbab665be6ac6310cdeed59950c96b31a519c'
'SKIP'
- 'c0218043e61da3921cd14579ae4a8774a6fdad91667a9fdb851d0a35f62edb48'
+ '060ad091ebfa2b63d62e86beaf68c3a5d4638c506c3ac941c1825ba756e830b1'
'SKIP'
- 'fbbae1d873900e84d1b7ef00593fbb94fc79f078a34b22ee824bab8b0a92be64'
- '756a168bbc3bb582f0df45b977c32af53658f21d62fe15171c9ac85f52d8852a'
+ '8a8a955f015ee8342701231a63836cec0e300fd7e96d30e8696fde8a383fcdc9'
+ '8b60911aad591306336e300e27071f2d108c5016e66a04327b82ac69acbfefff'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
- '1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
- '5313df7cb5b4d005422bd4cd0dae956b2dadba8f3db904275aaf99ac53894375'
- 'ab57037ecee0a425c612babdff47c831378bca0bff063a1308599989a350226d'
- '51586b733e9f178bebe577258b6057b035eded516ffe8bf8bbb26cb0b26c4958'
- 'ffbfaa192d17bfc7c6293aa9a07efe57f65177051ae3d8033d5e45a7bca2e0ad')
+ '1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99')
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
@@ -55,19 +48,6 @@ prepare() {
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
-
- # revert http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=9faac7b95ea4f9e83b7a914084cc81ef1632fd91
- # fixes #47778 sdhci broken on some boards
- # https://bugzilla.kernel.org/show_bug.cgi?id=106541
- patch -Rp1 -i "${srcdir}/0001-sdhci-revert.patch"
-
- # fixes #47805 kernel panics on platform modules
- # https://bugzilla.kernel.org/show_bug.cgi?id=110751
- patch -Np1 -i "${srcdir}/tpmdd-devel-v3-base-platform-fix-binding-for-drivers-without-probe-callback.patch"
-
- # #47757 fix broken suspend from btrfs and xfs
- patch -Np1 -i "${srcdir}/0001-4.4-revert-xfs.patch"
- patch -Np1 -i "${srcdir}/0001-4.4-revert-btrfs.patch"
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
@@ -124,7 +104,7 @@ _package() {
depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=0.7')
optdepends=('crda: to set the correct wireless channels of your country')
backup=("etc/mkinitcpio.d/${pkgbase}.preset")
- install=linux-tomoyo.install
+ install=${pkgbase}.install
cd "${srcdir}/${_srcname}"