summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Gorski2022-07-21 10:49:49 +0200
committerPiotr Gorski2022-07-21 10:49:49 +0200
commit58db746aa020052a33cd00e95901e9e34da2dc16 (patch)
tree2300a0ee8967962f6fbdfb514754a801b7b52a19 /PKGBUILD
parenta0deffe7dd87fbe97cb30fefc24001d05feac1d4 (diff)
downloadaur-58db746aa020052a33cd00e95901e9e34da2dc16.tar.gz
Cleaning, smoothing and adding some comments again
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 24 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 00dbbb7a6c7c..1ae424d09f90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -103,6 +103,7 @@ _disable_debug=y
## Enable zram/zswap ZSTD compression
_zstd_compression=y
+# Enable FULLCONENAT
_nf_cone=y
# Clang LTO mode, only available with the "llvm" compiler - options are "no", "full" or "thin".
@@ -116,6 +117,12 @@ _build_zfs=
# Enable bcachefs
_bcachefs=
+# Enable aufsfs
+_aufs=
+
+# Enable spadefs
+_spadfs=
+
if [ -n "$_use_llvm_lto" ]; then
pkgsuffix=${_cpusched}-lto
pkgbase=linux-$pkgsuffix
@@ -135,13 +142,14 @@ _stable=${_major}.${_minor}
_srcname=linux-${_stable}
#_srcname=linux-${_major}
pkgdesc='Linux TT scheduler Kernel by CachyOS with other patches and improvements'
-pkgrel=2
+pkgrel=4
_kernver=$pkgver-$pkgrel
arch=('x86_64' 'x86_64_v3')
url="https://github.com/CachyOS/linux-cachyos"
license=('GPL2')
options=('!strip')
-makedepends=('bc' 'texlive-latexextra' 'libelf' 'pahole' 'cpio' 'perl' 'tar' 'xz' 'zstd' 'xmlto' 'git' 'gcc' 'gcc-libs' 'glibc' 'binutils' 'make' 'patch')
+makedepends=('bc' 'libelf' 'pahole' 'cpio' 'perl' 'tar' 'xz' 'zstd' 'gcc' 'gcc-libs' 'glibc' 'binutils' 'make' 'patch')
+# LLVM makedepends
if [ -n "$_use_llvm_lto" ]; then
makedepends+=(clang llvm lld python)
BUILD_FLAGS=(
@@ -151,6 +159,11 @@ if [ -n "$_use_llvm_lto" ]; then
LLVM_IAS=1
)
fi
+# ZFS makedepends
+if [ -n "$_build_zfs" ]; then
+ makedepends+=(git)
+
+fi
_patchsource="https://raw.githubusercontent.com/ptr1337/kernel-patches/master/${_major}"
source=(
"https://cdn.kernel.org/pub/linux/kernel/v${pkgver%%.*}.x/${_srcname}.tar.xz"
@@ -188,6 +201,15 @@ fi
if [ -n "$_bcachefs" ]; then
source+=("${_patchsource}/0001-bcachefs-after-lru.patch")
fi
+
+if [ -n "$_aufs" ]; then
+source+=("${_patchsource}/0001-aufs-20220620.patch")
+fi
+
+if [ -n "$_spadfs" ]; then
+source+=("${_patchsource}/0001-spadfs-5.18-merge-v1.0.16.patch")
+fi
+
export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH})"