summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Gorski2022-11-15 16:54:59 +0100
committerPiotr Gorski2022-11-15 16:54:59 +0100
commit611e93d80f32e977e5887a17ed45c7a7249316f7 (patch)
tree8242eda202d99b520d917e19ea745077faff1628 /PKGBUILD
parent3d43358609d72b85762e51e690594ebcf9a209a1 (diff)
downloadaur-611e93d80f32e977e5887a17ed45c7a7249316f7.tar.gz
Sync with Github
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 06c19dcf90c5..dd6f200a1ecf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,6 +21,10 @@ _cachy_config=${_cachy_config-'yes'}
# 'hardened' - select 'BORE Scheduler hardened' ## kernel with hardened config and hardening patches with the bore scheduler
_cpusched=${_cpusched-'tt'}
+## Apply some suggested sysctl values from the bore developer
+## These are adjusted to BORE
+_tune_bore=${_tune_bore-}
+
### BUILD OPTIONS
# Set these variables to ANYTHING that is not null to enable them
@@ -251,9 +255,13 @@ fi
if [ "$_cpusched" = "pds" ]; then
source+=("${_patchsource}/sched/0001-prjc-cachy.patch")
fi
-## BORE Scheduler
+## BORE Scheduler with latency_nice
if [ "$_cpusched" = "bore" ]; then
source+=("${_patchsource}/sched/0001-bore-cachy.patch")
+## BORE SYSCTL TUNING
+ if [ -n "$_tune_bore" ]; then
+ source+=("${_patchsource}/misc/0001-bore-tuning-sysctl.patch")
+ fi
fi
## CacULE Scheduler
if [ "$_cpusched" = "cacule" ]; then