summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Gorski2022-09-28 01:24:33 +0200
committerPiotr Gorski2022-09-28 01:24:33 +0200
commitc42c969334b8516dcf1a19d29d23bf6e77aa401b (patch)
tree8d79692323fd8067cf55738e65c9e8f7992d5681 /PKGBUILD
parentbca18d85df0c262eae844aa86e73a740477dd043 (diff)
downloadaur-c42c969334b8516dcf1a19d29d23bf6e77aa401b.tar.gz
Improve nest and latency nice flags
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6e154b49c2bb..8ea6b2c45cee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -272,11 +272,15 @@ if [ -n "$_bcachefs" ]; then
fi
## NEST Support
if [ -n "$_nest" ]; then
+ if [[ "$_cpusched" = "bore" || "$_cpusched" = "cfs" || "$_cpusched" = "hardened" ]]; then
source+=("${_patchsource}/sched/0001-NEST.patch")
+ fi
fi
## Latency NICE Support
if [ -n "$_latency_nice" ]; then
+ if [[ "$_cpusched" = "bore" || "$_cpusched" = "cfs" || "$_cpusched" = "hardened" ]]; then
source+=("${_patchsource}/misc/0001-Add-latency-priority-for-CFS-class.patch")
+ fi
fi
export KBUILD_BUILD_HOST=cachyos