summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdrian Perez de Castro2014-05-09 19:26:06 +0300
committerAdrian Perez de Castro2015-06-15 01:22:45 +0200
commitb55978f22019d02baaeb2f158cdc65b5d3c2e5b7 (patch)
treef30399e4ec80e81756bf778604d449d8042dceba /PKGBUILD
parent9b540b4d5a7f427f7b4235d239265886cd829078 (diff)
downloadaur-b55978f22019d02baaeb2f158cdc65b5d3c2e5b7.tar.gz
Use tarballs instead of Git for fetching sources
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 6 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aa29c4a7d7d0..d935e516c5ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,23 @@
pkgname='linux-user-chroot'
pkgver='2013.1'
-pkgrel='1'
+pkgrel='2'
pkgdesc='setuid helper for making bind mounts and chrooting'
url='http://git.gnome.org/browse/linux-user-chroot/tree/README'
arch=('i686' 'x86_64')
license='GPL'
depends=('glibc')
-makedepends=('libxslt' 'git')
-repo="git://git.gnome.org/${pkgname}"
+makedepends=('git')
+source=("https://git.gnome.org/browse/${pkgname}/snapshot/${pkgname}-${pkgver}.tar.gz")
+sha1sums=('4d158e691732ad6e6be95203146c448bd64e90a0')
build () {
- cd "${srcdir}"
-
- msg "Connecting to the ${pkgname} Git repository..."
- if [ -d "${srcdir}/${pkgname}" ] ; then
- cd "${pkgname}" && git fetch origin
- msg "The local files are updated."
- else
- git clone "${repo}" "${pkgname}"
- fi
- cd "${srcdir}/${pkgname}"
-
- msg2 "Checking out version v${pkgver}"
- git checkout --force "v${pkgver}"
- msg "GIT checkout done or server timeout"
-
- msg2 "Configuring..."
+ cd "${srcdir}/${pkgname}-${pkgver}"
./autogen.sh --prefix=/usr --enable-newnet-helper
- msg2 "Compiling..."
make
}
package() {
- cd "${srcdir}/${pkgname}"
-
- msg2 "Packaging..."
+ cd "${srcdir}/${pkgname}-${pkgver}"
make install DESTDIR="${pkgdir}"
chmod +s "${pkgdir}/usr/bin"/linux-user-chroot{,-newnet}
}