summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHaruue Icymoon2018-05-09 11:42:33 +0800
committerHaruue Icymoon2018-05-09 11:42:33 +0800
commit56fa5075c217b9d0f3e20515224c854a08cc3177 (patch)
tree391c80b54a9adca90876ff63dde80b7e9ebb2792 /PKGBUILD
parentccc45f34d699ab4ea47424278f90e014963625dc (diff)
downloadaur-56fa5075c217b9d0f3e20515224c854a08cc3177.tar.gz
fix: build with gcc6
to avoid bug in gcc 8.1.0 that run out of memory if you're interested in this bug, just update gcc to 8.1.0, and try ulimit -m 1500000 -v 1500000 wget https://gist.githubusercontent.com/haruue/585c5d1387317e713bf9a1e81324fd06/raw/5b3adb7470edaa0255e38290f2d185025942431b/ubd_kern.i gcc ubd_kern.i Signed-off-by: Haruue Icymoon <haruue@caoyue.com.cn>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index daae0a6ad430..bd687451b584 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,19 +7,18 @@ pkgbase=linux-usermode
_kernelname=-usermodelinux
_srcname=linux-4.16
pkgver=4.16.7
-pkgrel=1
+pkgrel=2
pkgdesc="User mode Linux kernel and modules"
arch=('x86_64')
license=('GPL2')
url="http://user-mode-linux.sourceforge.net/"
depends=('coreutils')
-makedepends=('bc' 'inetutils' 'gcc<8.0')
+makedepends=('bc' 'inetutils' 'gcc6')
source=(
http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.{xz,sign}
http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.{xz,sign}
config)
-
sha256sums=('63f6dc8e3c9f3a0273d5d6f4dca38a2413ca3a5f689329d05b750e4c87bb21b9'
'SKIP'
'f5ef83461054024814846eb816c76eba1b903f7e3e38c3417027b33070b60d91'
@@ -53,7 +52,7 @@ build() {
cd "${srcdir}/${_srcname}"
unset LDFLAGS CFLAGS
- make ARCH=um vmlinux modules
+ make ARCH=um CC=gcc-6 vmlinux modules
}
package_linux-usermode() {