aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDan Ziemba2016-02-02 15:18:11 -0500
committerDan Ziemba2016-02-02 15:18:11 -0500
commit4e37f9fde22c7ede7027cee182a9a6dd052b5845 (patch)
treed2ce6e2ac2423161dc637941dde00c10becdc2bf /PKGBUILD
parenteb30161282941df9ae514526ee6f45cd25a9be1b (diff)
downloadaur-4e37f9fde22c7ede7027cee182a9a6dd052b5845.tar.gz
4.4.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 16 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d0e1a9422381..d899b48f4c57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgbase=linux-vfio
_srcname=linux-4.4
-pkgver=4.4
-pkgrel=4
+pkgver=4.4.1
+pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
license=('GPL2')
@@ -11,8 +11,8 @@ makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc')
options=('!strip')
source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.sign"
- #"https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
- #"https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.sign"
+ "https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
+ "https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.sign"
# the main kernel config files
'config' 'config.x86_64'
# standard config files for mkinitcpio ramdisk
@@ -20,18 +20,22 @@ source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'change-default-console-loglevel.patch'
'0001-sdhci-revert.patch'
'tpmdd-devel-v3-base-platform-fix-binding-for-drivers-without-probe-callback.patch'
- 'CVE-2016-0728.patch'
+ '0001-4.4-revert-btrfs.patch'
+ '0001-4.4-revert-xfs.patch'
'override_for_missing_acs_capabilities.patch'
'i915_317.patch')
sha256sums=('401d7c8fef594999a460d10c72c5a94e9c2e1022f16795ec51746b0d165418b2'
'SKIP'
- 'd402c67f5a7334ac9e242344055ef4ac63fe43a1d8f1cda82eddd59d7242a63e'
- 'ddeadf2910deb0803d4d4920c4dc7f07d3fb63bca564073aeb5f6181358f20d7'
+ 'c0218043e61da3921cd14579ae4a8774a6fdad91667a9fdb851d0a35f62edb48'
+ 'SKIP'
+ 'fbbae1d873900e84d1b7ef00593fbb94fc79f078a34b22ee824bab8b0a92be64'
+ '756a168bbc3bb582f0df45b977c32af53658f21d62fe15171c9ac85f52d8852a'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
'5313df7cb5b4d005422bd4cd0dae956b2dadba8f3db904275aaf99ac53894375'
'ab57037ecee0a425c612babdff47c831378bca0bff063a1308599989a350226d'
- '03bed5b1c6ef34a917e218a46d38cd1347c5ab5693131996113c6cad275dc4e9'
+ '51586b733e9f178bebe577258b6057b035eded516ffe8bf8bbb26cb0b26c4958'
+ 'ffbfaa192d17bfc7c6293aa9a07efe57f65177051ae3d8033d5e45a7bca2e0ad'
'975f79348119bfba8dd972a9fbfe6b38484c45bfd228f2f6d48a0c02426ba149'
'b5a8eebbe75e1801b35d2f5197eba6f57123c224e09e97a7eb526f1fa58ac918')
validpgpkeys=(
@@ -45,7 +49,7 @@ prepare() {
cd "${srcdir}/${_srcname}"
# add upstream patch
- #patch -p1 -i "${srcdir}/patch-${pkgver}"
+ patch -p1 -i "${srcdir}/patch-${pkgver}"
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
@@ -59,8 +63,9 @@ prepare() {
# https://bugzilla.kernel.org/show_bug.cgi?id=110751
patch -Np1 -i "${srcdir}/tpmdd-devel-v3-base-platform-fix-binding-for-drivers-without-probe-callback.patch"
- # fixes #47820 CVE-2016-0728.patch
- patch -Np1 -i "${srcdir}/CVE-2016-0728.patch"
+ # #47757 fix broken suspend from btrfs and xfs
+ patch -Np1 -i "${srcdir}/0001-4.4-revert-xfs.patch"
+ patch -Np1 -i "${srcdir}/0001-4.4-revert-btrfs.patch"
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream