aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDan Ziemba2015-07-02 23:40:34 -0400
committerDan Ziemba2015-07-02 23:40:34 -0400
commite2d4c7a106453e8d64fc6c4a46eedf912441f927 (patch)
treebd081dc2a44d3b6313e59b690f19e9cd4cf9c464 /PKGBUILD
parent8ba39a7187d99a218b0b83f8e3a0ee07309e4fbd (diff)
downloadaur-e2d4c7a106453e8d64fc6c4a46eedf912441f927.tar.gz
4.0.7-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 10 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a75fd2d3d32e..250711a01023 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=linux-vfio
_srcname=linux-4.0
pkgver=4.0.7
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
license=('GPL2')
@@ -17,6 +17,8 @@ source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'config' 'config.x86_64'
# standard config files for mkinitcpio ramdisk
'linux.preset'
+ '0001-block-loop-convert-to-per-device-workqueue.patch'
+ '0002-block-loop-avoiding-too-many-pending-per-work-I-O.patch'
'change-default-console-loglevel.patch'
'override_for_missing_acs_capabilities.patch'
'i915_317.patch'
@@ -28,6 +30,8 @@ sha256sums=('0f2f7d44979bc8f71c4fc5d3308c03499c26a824dd311fdf6eef4dee0d7d5991'
'e8d639582697f22333a96aa1614bcf5d9bcf2e6683a3d5296f9cfc64843606f1'
'5dadd75693e512b77f87f5620e470405b943373613eaf4df561037e9296453be'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
+ '0682df710e8d23f0d420b3b01fbfe409b3911940b1a379b78d9f4a5ac8590386'
+ 'af42b1456caee0b0db8f3cc770c78083b40159260b99db4930e503ac7824eacc'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
'975f79348119bfba8dd972a9fbfe6b38484c45bfd228f2f6d48a0c02426ba149'
'f86ce528b63f198b84c4d8d92d35329aa4000d462217dc2db03bac5eb693cf19')
@@ -49,6 +53,11 @@ prepare() {
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
+ # Fix deadlock with stacked loop devices (FS#45129)
+ # http://marc.info/?l=linux-kernel&m=143280649731902&w=2
+ patch -Np1 -i ../0001-block-loop-convert-to-per-device-workqueue.patch
+ patch -Np1 -i ../0002-block-loop-avoiding-too-many-pending-per-work-I-O.patch
+
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)