summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGoliathLabs2020-05-17 12:11:28 +0200
committerGoliathLabs2020-05-17 12:11:28 +0200
commitcf8d40e8198d4654187efb4fa7380719dd34b66d (patch)
treeaacc1c495cf59b3bde088353f4b129906154b6ab /PKGBUILD
parent3a4817d2a1f959a3ec0583879a31a274b78fd8f2 (diff)
downloadaur-cf8d40e8198d4654187efb4fa7380719dd34b66d.tar.gz
Updated: 4.19.123
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD73
1 files changed, 31 insertions, 42 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 35948c0de71c..67cadebdf334 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,27 @@
-# Maintainer: Pieter Lenaerts <pieter dot aj dot lenaerts at gmail>
+# Maintainer: Felix Golatofski <contact@xdfr.de>
+# Contributor: Pieter Lenaerts <pieter dot aj dot lenaerts at gmail>
# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: Thomas Baechler <thomas@archlinux.org>
pkgbase=linux-x205ta
-
-_srcver=4.19.4-arch1
-pkgver=${_srcver//-/.}
+pkgver=4.19.123
pkgrel=1
+pkgdesc='Linux Kernel with x205ta patches (LTS as there are no newer patches)'
+url="https://www.kernel.org/"
arch=(x86_64)
-url="https://git.archlinux.org/linux.git/log/?h=v$_srcver"
license=(GPL2)
-makedepends=(xmlto kmod inetutils bc libelf git python-sphinx graphviz)
+makedepends=(
+ bc kmod libelf
+ xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick
+)
options=('!strip')
-_srcname=archlinux-linux
+_srcname=linux-$pkgver
source=(
- "$_srcname::git+https://git.archlinux.org/linux.git?signed#tag=v$_srcver"
+ https://www.kernel.org/pub/linux/kernel/v${pkgver%%.*}.x/${_srcname}.tar.{xz,sign}
config # the main kernel config file
- 60-linux.hook # pacman hook for depmod
- 90-linux.hook # pacman hook for initramfs regeneration
- linux.preset # standard config files for mkinitcpio ramdisk
+ 0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
+ sphinx-workaround.patch
# Start x205ta sources
https://raw.githubusercontent.com/harryharryharry/x205ta-iso2usb-files/master/brcmfmac43340-sdio.txt
https://raw.githubusercontent.com/harryharryharry/x205ta-patches/master/4.18-patches/i915-pm-Be-less-agressive-with-clockfreq-changes-on-Bay-Trail.patch
@@ -30,21 +32,21 @@ source=(
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
- '8218F88849AAC522E94CF470A5E9288C4FA415FA' # Jan Alexander Steffens (heftig)
)
-sha256sums=('SKIP'
- '6d9d394a76d3e1fee4ea575aa38e2cd4b0e288d5deb8a502233a0e593018337a'
- 'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
- '75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
- 'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
+# https://www.kernel.org/pub/linux/kernel/v4.x/sha256sums.asc
+sha256sums=('a79914d31a8d8c6b0e2bb0f2b143d615fe8a6c4dd2e0f36e97aa20efd69a993f'
+ 'SKIP'
+ '4e68572e7cc4c5368f0236e0792660ae8498373988625dca46e509399a7eaea6'
+ 'a13581d3c6dc595206e4fe7fcf6b542e7a1bdbe96101f0f010fc5be49f99baf2'
+ 'a369e89baf2f87be196c7e044ca719ee2985beebfdaa16dcd4592afa52caea5c'
'aea75c0b07673f701856e3c2a35db33c041fdaf0bd5ef2927fb25b1bce2c2b62'
'5ad7e021452deffd387a5b81abcd0f608f8141eaab56fbdd162ca0b7966fc3b4'
'3845aeb3744372b716c668283b23972d76e482d8c69b107e13a13669e5671d06'
'ad0f318809d074ee387f48fdfcb711b0fa3eb378867ac65c6da3d490834e649d')
-
-_kernelname=${pkgbase#linux}
-: ${_kernelname:=-ARCH}
+export KBUILD_BUILD_HOST=archlinux
+export KBUILD_BUILD_USER=$pkgbase
+export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH})"
prepare() {
cd $_srcname
@@ -89,15 +91,13 @@ build() {
_package() {
pkgdesc="The ${pkgbase/linux/Linux} kernel and modules with harryharryharry's patches for the ASUS x205ta."
- [[ $pkgbase = linux ]] && groups=(base)
- depends=(coreutils linux-firmware kmod mkinitcpio)
- optdepends=('crda: to set the correct wireless channels of your country')
- backup=("etc/mkinitcpio.d/$pkgbase.preset")
- install=linux.install
-
- local kernver="$(<version)"
+ depends=(coreutils kmod initramfs)
+ optdepends=('crda: to set the correct wireless channels of your country'
+ 'linux-firmware: firmware images needed for some devices')
cd $_srcname
+ local kernver="$(<version)"
+ local modulesdir="$pkgdir/usr/lib/modules/$kernver"
msg2 "Installing boot image..."
install -Dm644 "$(make -s image_name)" "$pkgdir/boot/vmlinuz-$pkgbase"
@@ -125,18 +125,6 @@ _package() {
s|%EXTRAMODULES%|$extramodules|g
"
- # hack to allow specifying an initially nonexisting install file
- sed "$subst" "$startdir/$install" > "$startdir/$install.pkg"
- true && install=$install.pkg
-
- # fill in mkinitcpio preset and pacman hooks
- sed "$subst" ../linux.preset | install -Dm644 /dev/stdin \
- "$pkgdir/etc/mkinitcpio.d/$pkgbase.preset"
- sed "$subst" ../60-linux.hook | install -Dm644 /dev/stdin \
- "$pkgdir/usr/share/libalpm/hooks/60-$pkgbase.hook"
- sed "$subst" ../90-linux.hook | install -Dm644 /dev/stdin \
- "$pkgdir/usr/share/libalpm/hooks/90-$pkgbase.hook"
-
msg2 "Fixing permissions..."
chmod -Rc u=rwX,go=rX "$pkgdir"
}
@@ -148,8 +136,9 @@ _package-headers() {
cd $_srcname
- msg2 "Installing build files..."
- install -Dt "$builddir" -m644 Makefile .config Module.symvers System.map vmlinux
+ echo "Installing build files..."
+ install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map \
+ localversion.* version vmlinux
install -Dt "$builddir/kernel" -m644 kernel/Makefile
install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
cp -t "$builddir" -a scripts
@@ -160,7 +149,7 @@ _package-headers() {
# add xfs and shmem for aufs building
mkdir -p "$builddir"/{fs/xfs,mm}
- # ???
+ # this is gone in v5.3
mkdir "$builddir/.tmp_versions"
msg2 "Installing headers..."