summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCyano Hao2021-03-27 16:32:21 +0800
committerCyano Hao2021-03-27 16:49:15 +0800
commit142f7f15d41711901bd669b586b03405bc597060 (patch)
tree96ac5f4a7edb56db43b6b14f5480878ef7d10279 /PKGBUILD
parentf5032a4e273351106f0251ee5afa298996d8097e (diff)
downloadaur-142f7f15d41711901bd669b586b03405bc597060.tar.gz
remove docs: it costs too much time and is identical to `linux-docs`
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 4 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eaba0364bc1b..a8ff36e290c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=linux-x32
pkgver=5.11.10.arch1
-pkgrel=1
+pkgrel=2
pkgdesc='Linux with x32 ABI'
_srctag=v${pkgver%.*}-${pkgver##*.}
url="https://git.archlinux.org/linux.git/log/?h=$_srctag"
@@ -11,7 +11,6 @@ arch=(x86_64)
license=(GPL2)
makedepends=(
bc kmod libelf pahole cpio perl tar xz
- xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick
git
)
options=('!strip')
@@ -60,14 +59,14 @@ prepare() {
build() {
cd $_srcname
make all
- make htmldocs
}
_package() {
pkgdesc="The $pkgdesc kernel and modules"
depends=(coreutils kmod initramfs)
optdepends=('crda: to set the correct wireless channels of your country'
- 'linux-firmware: firmware images needed for some devices')
+ 'linux-firmware: firmware images needed for some devices'
+ 'linux-docs: documentation for Arch Linux’s distribution kernel')
provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
cd $_srcname
@@ -168,26 +167,7 @@ _package-headers() {
ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"
}
-_package-docs() {
- pkgdesc="Documentation for the $pkgdesc kernel"
-
- cd $_srcname
- local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
-
- echo "Installing documentation..."
- local src dst
- while read -rd '' src; do
- dst="${src#Documentation/}"
- dst="$builddir/Documentation/${dst#output/}"
- install -Dm644 "$src" "$dst"
- done < <(find Documentation -name '.*' -prune -o ! -type d -print0)
-
- echo "Adding symlink..."
- mkdir -p "$pkgdir/usr/share/doc"
- ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
-}
-
-pkgname=("$pkgbase" "$pkgbase-headers" "$pkgbase-docs")
+pkgname=("$pkgbase" "$pkgbase-headers")
for _p in "${pkgname[@]}"; do
eval "package_$_p() {
$(declare -f "_package${_p#$pkgbase}")