summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDevin Pohl2022-02-18 22:56:37 -0700
committerDevin Pohl2022-02-18 22:56:37 -0700
commit4cc201dbb560c6b9a247de7b30ce1ba068ebe5d9 (patch)
tree6506c55188b8bad465c69d0bedd36d17dc8924d1 /PKGBUILD
parente51acbd5e75ea0fdedc95f0cd2f4cc277f60e910 (diff)
downloadaur-4cc201dbb560c6b9a247de7b30ce1ba068ebe5d9.tar.gz
Updated to kernel 5.16.4, made some modifications to patches to build again
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 17 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c8073b6c6683..eddefd95ac7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Devin Pohl <pohl.devin@gmail.com>
pkgbase=linux-x570-vfio-openrgb-sm2262+sm2263
-pkgver=5.14.10.arch1
-pkgrel=4
+pkgver=5.16.4.arch1
+pkgrel=1
pkgdesc='Linux'
_srctag=v${pkgver%.*}-${pkgver##*.}
url="https://github.com/archlinux/linux/commits/$_srctag"
@@ -22,20 +22,21 @@ source=(
i915-vga-arbiter.patch
amd-noflr.patch
openrgb.patch
- SM2262-SM2263.patch
+ SM2262-SM2263.patch
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
'A2FF3A36AAA56654109064AB19802F8B0D70FC30' # Jan Alexander Steffens (heftig)
+ 'C7E7849466FE2358343588377258734B41C31549' # David Runge <dvzrv@archlinux.org>
)
sha256sums=('SKIP'
- 'cada4ca234a96e1f78da61ad29310bf076523d157ad55aadfc93465d3865c9e3'
+ '7cbba374356a189faac71001c5344ce8f02434684b1ce1accefc0cc4bd6718e5'
'b90be7b79652be61f7d50691000f6a8c75a240dc2eee2667b68d984f67583f77'
'856230cfbdc2bb53a4920dfbcb6fb2d58427b7b184e5f94e21f08011d0a2fcc6'
'37f306146b1bdf9233c544e87d0e392a8152aab679d0e4145d14f425c0438e23'
'e7d724ac15daf428aa1e6a03737e5c1d040892d55fda8a66897fcac9323f285c'
- '016715498862dcc7c29063c6b6ce9d5e4160eace594f6cb1f20de9783e077bd1')
+ 'df296b890108d6d419c455dd32b37de8b974fdeeb64cc797d6094a12502abdc8')
export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
@@ -60,13 +61,10 @@ prepare() {
echo "Setting config..."
cp ../config .config
- #make -j$(nproc) nconfig # new CLI menu for configuration
- #make -j$(nproc) menuconfig # CLI menu for configuration
- #make -j$(nproc) xconfig # X-based configuration
- make -j$(nproc) olddefconfig # using old config from previous kernel version
- # ... or manually edit .config
+ make olddefconfig
+ diff -u ../config .config || :
- make -j$(nproc) -s kernelrelease > version
+ make -s kernelrelease > version
echo "Prepared $pkgbase version $(<version)"
}
@@ -91,13 +89,13 @@ _package() {
echo "Installing boot image..."
# systemd expects to find the kernel here to allow hibernation
# https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
- install -Dm644 "$(make -j$(nproc) -s image_name)" "$modulesdir/vmlinuz"
+ install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
# Used by mkinitcpio to name the kernel
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
echo "Installing modules..."
- make -j$(nproc) INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
+ make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
# remove build and source links
rm "$modulesdir"/{source,build}
@@ -117,11 +115,11 @@ _package-headers() {
install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
cp -t "$builddir" -a scripts
- # add objtool for external module building and enabled VALIDATION_STACK option
+ # required when STACK_VALIDATION is enabled
install -Dt "$builddir/tools/objtool" tools/objtool/objtool
- # add xfs and shmem for aufs building
- mkdir -p "$builddir"/{fs/xfs,mm}
+ # required when DEBUG_INFO_BTF_MODULES is enabled
+ install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids
echo "Installing headers..."
cp -t "$builddir" -a include
@@ -131,10 +129,10 @@ _package-headers() {
install -Dt "$builddir/drivers/md" -m644 drivers/md/*.h
install -Dt "$builddir/net/mac80211" -m644 net/mac80211/*.h
- # http://bugs.archlinux.org/task/13146
+ # https://bugs.archlinux.org/task/13146
install -Dt "$builddir/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h
- # http://bugs.archlinux.org/task/20402
+ # https://bugs.archlinux.org/task/20402
install -Dt "$builddir/drivers/media/usb/dvb-usb" -m644 drivers/media/usb/dvb-usb/*.h
install -Dt "$builddir/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
install -Dt "$builddir/drivers/media/tuners" -m644 drivers/media/tuners/*.h
@@ -213,3 +211,4 @@ for _p in "${pkgname[@]}"; do
done
# vim:set ts=8 sts=2 sw=2 et:
+