summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoan Figueras2021-04-02 13:59:59 +0200
committerJoan Figueras2021-04-02 13:59:59 +0200
commit36fc01c140c23344a300209b885748ccba353d30 (patch)
tree5e9683ca658f19288f023dbe97dc4b34552768bb /PKGBUILD
parent5e564b11c2fc96354ac753d481764a6094684804 (diff)
downloadaur-36fc01c140c23344a300209b885748ccba353d30.tar.gz
hacky fix for xz patch not getting extracted, see discussion at URL in comments
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4f7465a7e134..9ecc1dbbf344 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -71,6 +71,7 @@ _srcname="linux-${pkgver}-xanmod${xanmod}"
source=("https://cdn.kernel.org/pub/linux/kernel/v${_branch}/linux-${_major}.tar."{xz,sign}
"https://github.com/xanmod/linux/releases/download/${pkgver}-xanmod${xanmod}/patch-${pkgver}-xanmod${xanmod}.xz"
choose-gcc-optimization.sh)
+ #"patch-${pkgver}-xanmod${xanmod}.xz::https://sourceforge.net/projects/xanmod/files/releases/stable/${pkgver}-xanmod${xanmod}/patch-${pkgver}-xanmod${xanmod}.xz/download"
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linux Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
@@ -96,6 +97,13 @@ export KBUILD_BUILD_TIMESTAMP=${KBUILD_BUILD_TIMESTAMP:-$(date -Ru${SOURCE_DATE_
prepare() {
cd linux-${_major}
+ # hacky work around for xz not getting extracted
+ # https://bbs.archlinux.org/viewtopic.php?id=265115
+ if [[ ! -f "$srcdir/patch-${pkgver}-xanmod${xanmod}" ]]; then
+ unlink "$srcdir/patch-${pkgver}-xanmod${xanmod}.xz"
+ xz -dc "$startdir/patch-${pkgver}-xanmod${xanmod}.xz" > "$srcdir/patch-${pkgver}-xanmod${xanmod}"
+ fi
+
# Apply Xanmod patch
patch -Np1 -i ../patch-${pkgver}-xanmod${xanmod}