summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoan Figueras2022-05-12 11:18:41 +0200
committerJoan Figueras2022-05-12 11:18:41 +0200
commit37e8b655e6e1fc54f71aa26e2ad9c9fcd861f243 (patch)
tree755f827bf80ae5555955b7c7cffc99946ed1ea49 /PKGBUILD
parentf03c1e3a1d472607aa336ef8dca1a984e741d627 (diff)
downloadaur-37e8b655e6e1fc54f71aa26e2ad9c9fcd861f243.tar.gz
5.17.6-xanmod1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0590819d644a..4dfe30229c0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,11 +31,20 @@ if [ -z ${use_tracers+x} ]; then
use_tracers=y
fi
+## NOTICE: clang config is not ready yet in 5.17.x
## Choose between GCC and CLANG config (default is GCC)
-if [ -z ${_compiler+x} ]; then
+if [ -z ${_compiler+x} ] || [ "$_compiler" = "clang" ]; then
_compiler=gcc
fi
+# Choose between the 3 main configs for EDGE branch. Default x86-64-v2 which use CONFIG_GENERIC_CPU2:
+# Possible values: config_x86-64 (default) / config_x86-64-v2 / config_x86-64-v3
+# This will be overwritten by selecting any option in microarchitecture script
+# Source files: https://github.com/xanmod/linux/tree/5.17/CONFIGS/xanmod/gcc
+if [ -z ${_config+x} ]; then
+ _config=config_x86-64
+fi
+
# Compress modules with ZSTD (to save disk space)
if [ -z ${_compress_modules+x} ]; then
_compress_modules=n
@@ -61,8 +70,8 @@ fi
### IMPORTANT: Do no edit below this line unless you know what you're doing
pkgbase=linux-xanmod
-_major=5.15
-pkgver=${_major}.36
+_major=5.17
+pkgver=${_major}.6
_branch=5.x
xanmod=1
pkgrel=${xanmod}
@@ -97,9 +106,9 @@ for _patch in ${_patches[@]}; do
source+=("${_patch}::https://raw.githubusercontent.com/archlinux/svntogit-packages/${_commit}/trunk/${_patch}")
done
-sha256sums=('57b2cf6991910e3b67a1b3490022e8a0674b6965c74c12da1e99d138d1991ee8'
+sha256sums=('555fef61dddb591a83d62dd04e252792f9af4ba9ef14683f64840e46fa20b1b1'
'SKIP'
- '04d763e02ef3490ca439fded8df3c629900a5a7ff4fe484d909158afe3cc6e40'
+ '6ec09e74f3f04e47d5b1925dda7d911a45c4a61d525e5e53814a1640599cde98'
'1ac18cad2578df4a70f9346f7c6fccbb62f042a0ee0594817fdef9f2704904ee')
export KBUILD_BUILD_HOST=${KBUILD_BUILD_HOST:-archlinux}
@@ -128,7 +137,7 @@ prepare() {
done
# Applying configuration
- cp -vf CONFIGS/xanmod/${_compiler}/config .config
+ cp -vf CONFIGS/xanmod/${_compiler}/${_config} .config
# enable LTO_CLANG_THIN
if [ "${_compiler}" = "clang" ]; then
scripts/config --disable LTO_CLANG_FULL