summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoan Figueras2025-02-23 12:46:05 +0100
committerJoan Figueras2025-02-23 12:46:05 +0100
commit78f55d9b2f561c86dc7838cba31eddded2dad468 (patch)
tree50ae965f826860a2fb43e759bcc5f50acdc5fca4 /PKGBUILD
parent7c11c1f05ec65fdf92200d5fd3c8b967c4831f11 (diff)
downloadaur-78f55d9b2f561c86dc7838cba31eddded2dad468.tar.gz
Fixed build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 89e8a672d6f5..29cb9782c31d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -43,9 +43,9 @@ fi
# Possible values: config_x86-64-v1 / config_x86-64-v2 (default) / config_x86-64-v3
# This will be overwritten by selecting any option in microarchitecture script
# Source files: https://gitlab.com/xanmod/linux/-/tree/6.12/CONFIGS/xanmod/gcc?ref_type=heads
-if [ -z ${_config+x} ]; then
- _config=config_x86-64-v2
-fi
+#if [ -z ${_config+x} ]; then
+ _config=config
+#fi
# Compress modules with ZSTD (to save disk space)
if [ -z ${_compress_modules+x} ]; then
@@ -78,7 +78,7 @@ _branch=6.x
xanmod=1
_revision=
_sf_branch=main
-pkgrel=${xanmod}
+pkgrel=2
pkgdesc='Linux Xanmod - Stable Mainline [MAIN]'
url="http://www.xanmod.org/"
arch=(x86_64)
@@ -118,7 +118,7 @@ done
sha256sums=('e79dcc6eb86695c6babfb07c2861912b635d5075c6cd1cd0567d1ea155f80d6e'
'SKIP'
'd8ccb0e826ec74ebc9e010209ee625f5952c7c71a43cd09cdd2a3555e4451b91'
- 'a8b38eb482eb685944757182c4886404abc12703e5e56ec39c7d61298d17d71f')
+ '252688b672d7a6982c28120a9509d63d8dda230e3a21bafd1177819ca161c88f')
export KBUILD_BUILD_HOST=${KBUILD_BUILD_HOST:-archlinux}
export KBUILD_BUILD_USER=${KBUILD_BUILD_USER:-makepkg}
@@ -146,7 +146,7 @@ prepare() {
done
# Applying configuration
- cp -vf CONFIGS/xanmod/gcc/${_config} .config
+ cp -vf CONFIGS/x86_64/${_config} .config
# enable LTO_CLANG_THIN
if [ "${_compiler}" = "clang" ]; then
scripts/config --disable LTO_CLANG_FULL