summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoan Figueras2021-06-11 15:00:54 +0200
committerJoan Figueras2021-06-11 15:00:54 +0200
commit7bce5345af1bab4b8c21ccd4937add0e07d2177b (patch)
treefbd426ee1354ff5c0d2389fb93edc4e1a8146823 /PKGBUILD
parentbada4d31f21e64ff4a611e3d05fe1b5f7553db88 (diff)
downloadaur-7bce5345af1bab4b8c21ccd4937add0e07d2177b.tar.gz
Fixed clang build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cb884f2cc674..fce3f15fb238 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -196,7 +196,11 @@ prepare() {
build() {
cd linux-${_major}
- make all
+ if [ "${_compiler}" = "clang" ]; then
+ make LLVM=1 LLVM_IAS=1 all
+ else
+ make all
+ fi
}
_package() {