summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMiklós Tóth2021-01-25 00:07:59 +0000
committerMiklós Tóth2021-01-25 00:07:59 +0000
commit34716e7fa50f7a97287c74a1d038c3058a87e2d0 (patch)
tree4e50a87dc2688edfd9478c8eb48ba8d24a000172 /PKGBUILD
parent71658a826c51715def5aceb0e93ad4992a4e9626 (diff)
downloadaur-34716e7fa50f7a97287c74a1d038c3058a87e2d0.tar.gz
automatic update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 16 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d630e26b85d3..d3e5071cbd14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -180,21 +180,23 @@ prepare() {
sh ${srcdir}/choose-gcc-optimization.sh $_microarchitecture
# This is intended for the people that want to build this package with their own config
- # Put the file "myconfig" at the package folder to use this feature
- # If it's a full config, will be replaced
- # If not, you should use scripts/config commands, one by line
- if [ -f "${startdir}/myconfig" ]; then
- if ! grep -q 'scripts/config' "${startdir}/myconfig"; then
- # myconfig is a full config file. Replacing default .config
- msg2 "Using user CUSTOM config..."
- cp -f "${startdir}"/myconfig .config
- else
- # myconfig is a partial file. Executing as a script
- msg2 "Applying myconfig..."
- bash -x "${startdir}"/myconfig
+ # Put the file "myconfig" at the package folder (this will take preference) or "${XDG_CONFIG_HOME}/linux-xanmod-anbox/myconfig"
+ # If we detect partial file with scripts/config commands, we execute as a script
+ # If not, it's a full config, will be replaced
+ for _myconfig in "${startdir}/myconfig" "${XDG_CONFIG_HOME}/linux-xanmod-anbox/myconfig" ; do
+ if [ -f "${_myconfig}" ]; then
+ if grep -q 'scripts/config' "${_myconfig}"; then
+ # myconfig is a partial file. Executing as a script
+ msg2 "Applying myconfig..."
+ bash -x "${_myconfig}"
+ else
+ # myconfig is a full config file. Replacing default .config
+ msg2 "Using user CUSTOM config..."
+ cp -f "${_myconfig}" .config
+ fi
+ echo
fi
- echo
- fi
+ done
make olddefconfig