summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoan Figueras2021-06-11 15:04:16 +0200
committerJoan Figueras2021-06-11 15:04:16 +0200
commit7d21c54f9c8a9741ac821c83a31250f44229df77 (patch)
treefa15aefc404b8121dcc19061969b23ad41e7772f /PKGBUILD
parentd579969b75ebcea6f08c0f713f6ce30735d65176 (diff)
downloadaur-7d21c54f9c8a9741ac821c83a31250f44229df77.tar.gz
Fixed clang build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9002c566aae2..ed4f7a30c9c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -195,7 +195,11 @@ prepare() {
build() {
cd linux-${_major}
- make all
+ if [ "${_compiler}" = "clang" ]; then
+ make LLVM=1 LLVM_IAS=1 all
+ else
+ make all
+ fi
}
_package() {