summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoan Figueras2021-02-26 00:09:24 +0100
committerJoan Figueras2021-02-26 00:09:24 +0100
commit9cdb3a079e96f58dfe72a6a6626dfd920d911846 (patch)
tree1824e1fa6cf56b25f5235592aff8bf4c72364d50 /PKGBUILD
parent5f9db260b81e82ebbbc742a4ec087147b59b3a44 (diff)
downloadaur-9cdb3a079e96f58dfe72a6a6626dfd920d911846.tar.gz
5.11.1-xanmod2-cacule
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 12 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 571731f79e64..d7729ade919a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -34,14 +34,7 @@ if [ -z ${use_tracers+x} ]; then
use_tracers=y
fi
-## Enable CONFIG_USER_NS_UNPRIVILEGED flag https://aur.archlinux.org/cgit/aur.git/tree/0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch?h=linux-ck
-## Set variable "use_ns" to: n to disable (stock Xanmod)
-## y to enable (stock Archlinux)
-if [ -z ${use_ns+x} ]; then
- use_ns=n
-fi
-
-# Compile ONLY used modules to VASTLYreduce the number of modules built
+# Compile ONLY used modules to VASTLY reduce the number of modules built
# and the build time.
#
# To keep track of which modules are needed for your specific system/hardware,
@@ -59,10 +52,10 @@ _makenconfig=
### IMPORTANT: Do no edit below this line unless you know what you're doing
pkgbase=linux-xanmod-cacule
-pkgver=5.10.16
-_major=5.10
+pkgver=5.11.1
+_major=5.11
_branch=5.x
-xanmod=1
+xanmod=2
pkgrel=${xanmod}
pkgdesc='Linux Xanmod. Branch with Cacule scheduler by Hamad Marri'
url="http://www.xanmod.org/"
@@ -77,24 +70,24 @@ _srcname="linux-${pkgver}-xanmod${xanmod}"
source=("https://cdn.kernel.org/pub/linux/kernel/v${_branch}/linux-${_major}.tar."{xz,sign}
"https://github.com/xanmod/linux/releases/download/${pkgver}-xanmod${xanmod}-cacule/patch-${pkgver}-xanmod${xanmod}-cacule.xz"
- choose-gcc-optimization.sh
- '0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-CLONE_NEWUSER.patch')
+ choose-gcc-optimization.sh)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linux Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
# Archlinux patches
-_commits=""
-for _patch in $_commits; do
- source+=("${_patch}.patch::https://git.archlinux.org/linux.git/patch/?id=${_patch}")
+_commit="be7d4710850020de55bce930c83fa80347c02fc3"
+_patches=("sphinx-workaround.patch")
+for _patch in ${_patches[@]}; do
+ source+=("${_patch}::https://git.archlinux.org/svntogit/packages.git/plain/trunk/${_patch}?h=packages/linux&id=${_commit}")
done
-sha256sums=('dcdf99e43e98330d925016985bfbc7b83c66d367b714b2de0cbbfcbf83d8ca43'
+sha256sums=('04f07b54f0d40adfab02ee6cbd2a942c96728d87c1ef9e120d0cb9ba3fe067b4'
'SKIP'
- 'e1c108a65a34c1ed2474a8296a517025fcb26c018bf1b4c02bc12b42487de000'
+ 'ef0f0d9bc504a77c7e11c07899b12193854bafaa8c8354ab08e6005bf3b68e7f'
'03bb8b234a67b877a34a8212936ba69d8700c54c7877686cbd9742a536c87134'
- '6c66dba73251440352f93ff32b72f5dd49536d0f17ef9347867660fd3a626991')
+ '52fc0fcd806f34e774e36570b2a739dbdf337f7ff679b1c1139bee54d03301eb')
export KBUILD_BUILD_HOST=${KBUILD_BUILD_HOST:-archlinux}
export KBUILD_BUILD_USER=${KBUILD_BUILD_USER:-makepkg}
@@ -140,11 +133,6 @@ prepare() {
scripts/config --disable CONFIG_NUMA
fi
- if [ "$use_ns" = "n" ]; then
- msg2 "Disabling CONFIG_USER_NS_UNPRIVILEGED"
- scripts/config --disable CONFIG_USER_NS_UNPRIVILEGED
- fi
-
# Let's user choose microarchitecture optimization in GCC
sh ${srcdir}/choose-gcc-optimization.sh $_microarchitecture