summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoan Figueras2021-03-02 23:53:58 +0100
committerJoan Figueras2021-03-02 23:53:58 +0100
commita67b249876dcd123aaa94c905fdce5a7ddbb8463 (patch)
tree54166fdb187e4d8a1a093db711345532ff570319 /PKGBUILD
parent9cdb3a079e96f58dfe72a6a6626dfd920d911846 (diff)
downloadaur-a67b249876dcd123aaa94c905fdce5a7ddbb8463.tar.gz
Merged Arch PKGBUILD changes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d7729ade919a..2d463d79c078 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -202,14 +202,15 @@ _package() {
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
msg2 "Installing modules..."
- make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
+ make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
# remove build and source links
rm "$modulesdir"/{source,build}
}
_package-headers() {
- pkgdesc="Header files and scripts for building modules for Xanmod Linux kernel"
+ pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
+ depends=(pahole)
cd linux-${_major}
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
@@ -278,6 +279,8 @@ _package-headers() {
esac
done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
+ msg2 "Stripping vmlinux..."
+ strip -v $STRIP_STATIC "$builddir/vmlinux"
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/src"
ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"