summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoan Figueras2022-01-29 16:06:16 +0100
committerJoan Figueras2022-01-29 16:06:16 +0100
commit8d368021b4dcd066bc20a105a7ac585784b31d15 (patch)
tree23babb552a2dbed2717a9ea4568892bc1834c966 /PKGBUILD
parente17b395948c5c3629d510594e9aa1131156ab762 (diff)
downloadaur-8d368021b4dcd066bc20a105a7ac585784b31d15.tar.gz
Convert _makenconfig as external variable, as requested by Gobidev
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 29c60b459d59..d6b47ba39159 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -54,7 +54,9 @@ if [ -z ${_localmodcfg} ]; then
fi
# Tweak kernel options prior to a build via nconfig
-_makenconfig=
+if [ -z ${_makenconfig} ]; then
+ _makenconfig=n
+fi
### IMPORTANT: Do no edit below this line unless you know what you're doing
@@ -199,7 +201,9 @@ prepare() {
make -s kernelrelease > version
msg2 "Prepared %s version %s" "$pkgbase" "$(<version)"
- [[ -z "$_makenconfig" ]] || make LLVM=$_LLVM LLVM_IAS=$_LLVM nconfig
+ if [ "$_makenconfig" = "y" ]; then
+ make LLVM=$_LLVM LLVM_IAS=$_LLVM nconfig
+ fi
# save configuration for later reuse
cat .config > "${SRCDEST}/config.last"