summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoan Figueras2020-10-15 00:38:27 +0200
committerJoan Figueras2020-10-15 00:38:27 +0200
commite1fd53fffc3dd93f98f2b42d760bfd65450ccda7 (patch)
treefa7cb05fad0f8abbfaef03d8532e10284608010c /PKGBUILD
parent3ec732a81d93cfefab315f7dfdcfd0dc42980a6d (diff)
downloadaur-e1fd53fffc3dd93f98f2b42d760bfd65450ccda7.tar.gz
Changed myconfig logic
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4cc9ad825032..6239f9ff8620 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -167,8 +167,8 @@ prepare() {
# If it's a full config, will be replaced
# If not, you should use scripts/config commands, one by line
if [ -f "${startdir}/myconfig" ]; then
- if [ $(wc -l < "${startdir}/myconfig") -gt 5000 ]; then
- # myconfig is a full config file. Replace it
+ if ! grep -q 'scripts/config' "${startdir}/myconfig"; then
+ # myconfig is a full config file. Replacing default .config
msg2 "Using user CUSTOM config..."
cp -f "${startdir}"/myconfig .config
else