summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoan Figueras2021-04-02 14:04:33 +0200
committerJoan Figueras2021-04-02 14:04:33 +0200
commit8f1701853124a4e07a75ec04a8e8476106067338 (patch)
treef559b43bbabc65d3b1f5afa4f9245ee61e820990 /PKGBUILD
parente7048b6ce9c7eada97346d50c26e35e567091847 (diff)
downloadaur-8f1701853124a4e07a75ec04a8e8476106067338.tar.gz
hacky fix for xz patch not getting extracted, see discussion at URL in comments
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4d8e2b0a581c..a3ac3bce3637 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -102,6 +102,13 @@ export KBUILD_BUILD_TIMESTAMP=${KBUILD_BUILD_TIMESTAMP:-$(date -Ru${SOURCE_DATE_
prepare() {
cd linux-${_major}
+ # hacky work around for xz not getting extracted
+ # https://bbs.archlinux.org/viewtopic.php?id=265115
+ if [[ ! -f "$srcdir/patch-${pkgver}-xanmod${xanmod}" ]]; then
+ unlink "$srcdir/patch-${pkgver}-xanmod${xanmod}.xz"
+ xz -dc "$startdir/patch-${pkgver}-xanmod${xanmod}.xz" > "$srcdir/patch-${pkgver}-xanmod${xanmod}"
+ fi
+
# Apply Xanmod patch
patch -Np1 -i ../patch-${pkgver}-xanmod${xanmod}