aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorScott B2021-10-27 15:17:46 -0700
committerScott B2021-10-29 03:47:50 -0700
commit162090853f512ca89972cff205eac7a1c5c14d42 (patch)
tree05310c1e3bf58e392246bfeb907b0f5128fe736a /PKGBUILD
parent5c6319b009780efb789f5ef4229912e1c1ecd620 (diff)
downloadaur-162090853f512ca89972cff205eac7a1c5c14d42.tar.gz
config: actually fix dyndbg parse errors
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 12 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4c2f5522ec8e..8f73b74e8e7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -335,6 +335,18 @@ prepare() {
# NOTE: this script must run *after* make olddefconfig so any new uarch macros exist
sh "${srcdir}/choose-gcc-optimization.sh" $_microarchitecture
+ ## bake in s0ix debugging parameters
+ scripts/config --enable CONFIG_CMDLINE_BOOL \
+ --set-str CONFIG_CMDLINE "makepkgplaceholderyolo" \
+ --disable CMDLINE_OVERRIDE
+
+ ## HACK: forcibly fixup CONFIG_CMDLINE as scripts/config mangles quote escapes
+
+ # note the double escaped quotes here, sed strips one;
+ # the final result in .config needs to look like CONFIG_CMDLINE="foo.dyndbg=\"+p\"" to avoid dyndbg parse errors at boot
+
+ sed -i 's#makepkgplaceholderyolo#pm_debug_messages amd_pmc.enable_stb=1 amd_pmc.dyndbg=\\"+p\\" acpi.dyndbg=\\"file drivers/acpi/x86/s2idle.c +p\\"#' .config
+
make -s kernelrelease > version
msg2 "Prepared %s version %s" "$pkgbase" "$(<version)"