aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorScott B2021-10-19 02:03:13 -0700
committerAntoine Viallon2021-10-25 10:18:41 +0200
commita3ca33b2758ac05efb5e220e323ab7553d362d8a (patch)
tree3809dd91c3e05e2fe44dd72905afc0fb688a5fec /PKGBUILD
parentaa8fdc862fc893d3101391430eeb6afac4f4c0aa (diff)
downloadaur-a3ca33b2758ac05efb5e220e323ab7553d362d8a.tar.gz
housekeeping: comments
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 4 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7c7a650ce9db..12eeda7c280c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,10 +16,9 @@
##
## build with 'env use_uksm=foo makepkg ...' to include UKSM patch
##
-## NOTE: Don't enable UKSM and LRU_GEN together at runtime, they are incompatible and will crash
-## If UKSM is enabled during build LRU_GEN will be disabled by default in the kernel config
+## NOTE: Don't enable UKSM and LRU_GEN together at runtime, they are incompatible and will crash.
+## If UKSM is enabled during build LRU_GEN will be boot-time disabled in the kernel config
## You can still switch between them at runtime but do *not* attempt to use both.
-##
if [[ -v use_uksm ]]; then
use_uksm=y
fi
@@ -214,8 +213,6 @@ export KBUILD_BUILD_TIMESTAMP=${KBUILD_BUILD_TIMESTAMP:-$(date -Ru${SOURCE_DATE_
prepare() {
cd "linux-${_major}"
- # WARN: mangle Makefile versions here if needed to apply patches cleanly
-
# Apply patches
local src
for src in "${source[@]}"; do
@@ -240,8 +237,6 @@ prepare() {
esac
done
- # WARN: mangle Makefile versions here if needed before calling setlocalversion
-
msg2 "Setting version..."
scripts/setlocalversion --save-scmversion
echo "-$pkgrel" > localversion.99-pkgrel
@@ -319,7 +314,8 @@ prepare() {
make LLVM=$_LLVM LLVM_IAS=$_LLVM olddefconfig
- # let user choose microarchitecture optimization target; NOTE: must run *after* make olddefconfig so any new uarch macros exist
+ # let user choose microarchitecture optimization target;
+ # NOTE: this script must run *after* make olddefconfig so any new uarch macros exist
sh "${srcdir}/choose-gcc-optimization.sh" $_microarchitecture
make -s kernelrelease > version