aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorScott B2021-09-15 16:39:43 -0700
committerAntoine Viallon2021-10-25 10:18:32 +0200
commitecfc5cafc5b6f1a923d3c889fac6b93e3198ab55 (patch)
treefb7ebaa605bc060b9100976a5947de617f86f5de /PKGBUILD
parent8dbe2cea2d5b3b806401754895dd5b5f1acb2368 (diff)
downloadaur-ecfc5cafc5b6f1a923d3c889fac6b93e3198ab55.tar.gz
5.14.5.xanpre0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8741dc24435d..4fb7d55a1fc5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -77,9 +77,9 @@ _makenconfig=
pkgbase=linux-xanmod-rog
xanmod=5.14.4-xanmod1
-pkgver=${xanmod//-/.}
-#pkgver=5.14.4.xanpre0 # NOTE: start 4th position with 'xan...', we rely on parsing for '.xan...' later
-pkgrel=2
+#pkgver=${xanmod//-/.}
+pkgver=5.14.5.xanpre0 # NOTE: start 4th position with 'xan...', we rely on parsing for '.xan...' later
+pkgrel=1
pkgdesc='Linux Xanmod'
url="http://www.xanmod.org/"
arch=(x86_64)
@@ -103,8 +103,9 @@ source=("https://cdn.kernel.org/pub/linux/kernel/v${_branch}/linux-${_major}.tar
"sphinx-workaround.patch"
# incremental kernel.org patch ahead of official Xanmod release
- #"https://cdn.kernel.org/pub/linux/kernel/v5.x/incr/patch-5.14.3-4.xz"
+ "https://cdn.kernel.org/pub/linux/kernel/v5.x/incr/patch-5.14.4-5.xz"
#"https://cdn.kernel.org/pub/linux/kernel/v5.x/patch-5.14.1.xz"
+ #"Linux-5.14.5-rc1.patch"
# don't drop shared caches on C3 state transitions
"x86-ACPI-State-Optimize-C3-entry-on-AMD-CPUs.patch" # landing in 5.15
@@ -159,6 +160,7 @@ sha256sums=('7e068b5e0d26a62b10e5320b25dce57588cbbc6f781c090442138c9c9c3271b2'
'd5c166c07c346edf3a49089233096eefb5364eb7370c4a6da3346e771bf4e7ed'
'1ac18cad2578df4a70f9346f7c6fccbb62f042a0ee0594817fdef9f2704904ee'
'52fc0fcd806f34e774e36570b2a739dbdf337f7ff679b1c1139bee54d03301eb'
+ '003a74e488e35ec7c4c45b1e1918ef6bf54d335a5202d1107f27e1209a6ea134'
'923230ed8367e28adfdeed75d3cdba9eec6b781818c37f6f3d3eb64101d2e716'
'f7a4bf6293912bfc4a20743e58a5a266be8c4dbe3c1862d196d3a3b45f2f7c90'
'de8c9747637768c4356c06aa65c3f157c526aa420f21fdd5edd0ed06f720a62e'
@@ -208,7 +210,7 @@ prepare() {
# WARN: mangle Makefile versions here if needed so patches apply cleanly
## Monkey patch: apply kernel.org patches when mainline is slightly ahead of Xanmod official
- #patch -Np1 -i ../patch-5.14.3-4
+ patch -Np1 -i ../patch-5.14.4-5
# Archlinux patches
local src