summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoan Figueras2023-12-02 10:20:20 +0100
committerJoan Figueras2023-12-02 10:20:20 +0100
commit93f1e7250e90d73a7293f913acbd36d13b1abf1e (patch)
treeaaa3ee87256f8a4bfb8c18dcc13a4f6fce110c34 /PKGBUILD
parentf62bba0514e6f2d7ecac9b8891f66775d8ab8402 (diff)
downloadaur-93f1e7250e90d73a7293f913acbd36d13b1abf1e.tar.gz
6.1.64-rt17-xanmod1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD59
1 files changed, 39 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 81cde3d3ea16..302e0c141213 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Joan Figueras <ffigue at gmail dot com>
# Contributor: Torge Matthies <openglfreak at googlemail dot com>
-# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
##
## The following variables can be customized at build time. Use env or export to change at your wish
@@ -73,9 +73,9 @@ fi
pkgbase=linux-xanmod-rt
_major=6.1
-pkgver=${_major}.59
+pkgver=${_major}.64
_branch=6.x
-_rt=16
+_rt=17
xanmod=1
_revision=
_sf_branch=rt
@@ -86,7 +86,15 @@ arch=(x86_64)
license=(GPL2)
makedepends=(
- bc cpio kmod libelf perl tar xz
+ bc
+ cpio
+ gettext
+ libelf
+ pahole
+ perl
+ python
+ tar
+ xz
)
if [ "${_compiler}" = "clang" ]; then
makedepends+=(clang llvm lld python)
@@ -106,13 +114,12 @@ validpgpkeys=(
_commit="ec9e9a4219fe221dec93fa16fddbe44a34933d8d"
_patches=()
for _patch in ${_patches[@]}; do
- #source+=("${_patch}::https://git.archlinux.org/svntogit/packages.git/plain/trunk/${_patch}?h=packages/linux&id=${_commit}")
source+=("${_patch}::https://raw.githubusercontent.com/archlinux/svntogit-packages/${_commit}/trunk/${_patch}")
done
sha256sums=('2ca1f17051a430f6fed1196e4952717507171acfd97d96577212502703b25deb'
'SKIP'
- '5a22f50b84a7f40a2c06182830b38f55ba8bd08f297bd98513101de2fdc64726'
+ 'a05a8e75178714b2858c870e0d571b5258b46d6504d9d0e9fdd20fbc2d7bfa5b'
'a8b38eb482eb685944757182c4886404abc12703e5e56ec39c7d61298d17d71f')
export KBUILD_BUILD_HOST=${KBUILD_BUILD_HOST:-archlinux}
@@ -236,17 +243,28 @@ build() {
_package() {
pkgdesc="The Linux kernel and modules with Xanmod patches"
- depends=(coreutils kmod initramfs)
- optdepends=('crda: to set the correct wireless channels of your country'
- 'linux-firmware: firmware images needed for some devices')
- provides=(VIRTUALBOX-GUEST-MODULES
- WIREGUARD-MODULE
- KSMBD-MODULE
- NTFS3-MODULE)
+ depends=(
+ coreutils
+ initramfs
+ kmod
+ )
+ optdepends=(
+ 'wireless-regdb: to set the correct wireless channels of your country'
+ 'linux-firmware: firmware images needed for some devices'
+ )
+ provides=(
+ KSMBD-MODULE
+ VIRTUALBOX-GUEST-MODULES
+ WIREGUARD-MODULE
+ NTFS3-MODULE
+ )
+ replaces=(
+ virtualbox-guest-modules-arch
+ wireguard-arch
+ )
cd linux-${_major}
- local kernver="$(<version)"
- local modulesdir="$pkgdir/usr/lib/modules/$kernver"
+ local modulesdir="$pkgdir/usr/lib/modules/$(<version)"
msg2 "Installing boot image..."
# systemd expects to find the kernel here to allow hibernation
@@ -257,10 +275,11 @@ _package() {
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
msg2 "Installing modules..."
- make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
+ ZSTD_CLEVEL=19 make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
+ DEPMOD=/doesnt/exist modules_install # Suppress depmod
- # remove build and source links
- rm "$modulesdir"/{source,build}
+ # remove build link
+ rm "$modulesdir"/build
}
_package-headers() {
@@ -325,7 +344,7 @@ _package-headers() {
msg2 "Stripping build tools..."
local file
while read -rd '' file; do
- case "$(file -bi "$file")" in
+ case "$(file -Sib "$file")" in
application/x-sharedlib\;*) # Libraries (.so)
strip -v $STRIP_SHARED "$file" ;;
application/x-archive\;*) # Libraries (.a)
@@ -339,7 +358,7 @@ _package-headers() {
msg2 "Stripping vmlinux..."
strip -v $STRIP_STATIC "$builddir/vmlinux"
-
+
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/src"
ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"