summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoan Figueras2021-12-18 23:20:08 +0100
committerJoan Figueras2021-12-18 23:20:08 +0100
commita430b014ab925bea28fc796a297e791deb017ee8 (patch)
tree63c3e2c92d878c5e1083e5906091f1476906ff76 /PKGBUILD
parent6563295bdf4ac83da7a1591127e4b677fa99d265 (diff)
downloadaur-a430b014ab925bea28fc796a297e791deb017ee8.tar.gz
5.15.8-rt23-xanmod1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 16 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7c2f4ab02b54..bcc617b37640 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -39,6 +39,11 @@ if [ -z ${_compiler+x} ]; then
_compiler=gcc
fi
+# Compress modules with ZSTD (to save disk space)
+if [ -z ${_compress_modules+x} ]; then
+ _compress_modules=n
+fi
+
# Compile ONLY used modules to VASTLY reduce the number of modules built
# and the build time.
#
@@ -57,10 +62,10 @@ _makenconfig=
### IMPORTANT: Do no edit below this line unless you know what you're doing
pkgbase=linux-xanmod-rt
-_major=5.13
-pkgver=${_major}.1
+_major=5.15
+pkgver=${_major}.8
_branch=5.x
-_rt=1
+_rt=23
xanmod=1
pkgrel=${xanmod}
pkgdesc='Linux Xanmod real-time version'
@@ -69,7 +74,7 @@ arch=(x86_64)
license=(GPL2)
makedepends=(
- xmlto kmod inetutils bc libelf cpio
+ bc cpio kmod libelf perl tar xz
)
if [ "${_compiler}" = "clang" ]; then
makedepends+=(clang llvm lld python)
@@ -93,9 +98,9 @@ for _patch in ${_patches[@]}; do
source+=("${_patch}::https://raw.githubusercontent.com/archlinux/svntogit-packages/${_commit}/trunk/${_patch}")
done
-sha256sums=('3f6baa97f37518439f51df2e4f3d65a822ca5ff016aa8e60d2cc53b95a6c89d9'
+sha256sums=('57b2cf6991910e3b67a1b3490022e8a0674b6965c74c12da1e99d138d1991ee8'
'SKIP'
- '5b8a5dceb10f17f2f8324cdee6a2aa23707ca9384e5046f8c7fbe1d4aa9d2442'
+ '4ee54b78aa5dec4707412ee488f5279228f298aed0380fd0675c2f6943439e03'
'1ac18cad2578df4a70f9346f7c6fccbb62f042a0ee0594817fdef9f2704904ee')
export KBUILD_BUILD_HOST=${KBUILD_BUILD_HOST:-archlinux}
@@ -153,6 +158,11 @@ prepare() {
scripts/config --disable CONFIG_NUMA
fi
+ # Compress modules by default (following Arch's kernel)
+ if [ "$_compress_modules" = "y" ]; then
+ scripts/config --enable CONFIG_MODULE_COMPRESS_ZSTD
+ fi
+
# Let's user choose microarchitecture optimization in GCC
sh ${srcdir}/choose-gcc-optimization.sh $_microarchitecture