summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFigue2020-01-14 16:11:01 +0100
committerFigue2020-01-14 16:11:01 +0100
commitae489b4fe649618554c0da515df9507895569114 (patch)
tree10eb4cad2bf12ad41658c1b3244d6076eb80b07d /PKGBUILD
parent8f1fe4265c275dfe36b5e2b099a90f961bf3d2a4 (diff)
downloadaur-ae489b4fe649618554c0da515df9507895569114.tar.gz
5.4.10-rt5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 17 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0c81781195a6..74c2c5cc2a19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -40,12 +40,21 @@ fi
if [ -z ${use_pds+x} ]; then
use_pds=n
fi
+##
+## Enable CONFIG_USER_NS_UNPRIVILEGED flag https://aur.archlinux.org/cgit/aur.git/tree/0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch?h=linux-ck
+## Set variable "use_ns" to: n to disable (stock Xanmod)
+## y to enable (stock Archlinux)
+if [ -z ${use_ns+x} ]; then
+ use_ns=n
+fi
+##
pkgbase=linux-xanmod-rt
-pkgver=5.4.5
-xanmod=3
+pkgver=5.4.10
+xanmod=5
pkgrel=1
_rev=
+pkgdesc='Linux Xanmod real-time version'
arch=(x86_64)
url="http://www.xanmod.org/"
license=(GPL2)
@@ -60,7 +69,7 @@ source=(https://github.com/xanmod/linux/archive/${pkgver}-rt${xanmod}-xanmod${_r
choose-gcc-optimization.sh
)
-sha256sums=('c8cb0c5c1a4131c37c8afcbbc73d4fee6891c8d25eb2201a1ac6a048353a93f9'
+sha256sums=('2e7f074bc7e54fed25c25097523079ae314cd599f5df8f66a8f4d3afd35f9ecf'
'8b2629f6340d4807c113cd9fa308f50f0a8d85df5698bef083e151f06d58f748')
export KBUILD_BUILD_HOST=archlinux
@@ -109,6 +118,11 @@ prepare() {
scripts/config --enable CONFIG_SCHED_PDS
fi
+ if [ "$use_ns" = "n" ]; then
+ msg2 "Disabling CONFIG_USER_NS_UNPRIVILEGED"
+ scripts/config --disable CONFIG_USER_NS_UNPRIVILEGED
+ fi
+
# Let's user choose microarchitecture optimization in GCC
sh ${srcdir}/choose-gcc-optimization.sh $_microarchitecture