summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoan Figueras2021-07-09 00:25:24 +0200
committerJoan Figueras2021-07-09 00:25:24 +0200
commit0a46ec42d34123cc034f8d31163ce3aa8dc6260f (patch)
tree86af6e8bcc67122325fc8cbb78c9d3cd439b9916 /PKGBUILD
parentf1fc8946880f2471344ddb5d3ac22198af4011d6 (diff)
downloadaur-0a46ec42d34123cc034f8d31163ce3aa8dc6260f.tar.gz
Fixed build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7741fc71ea8f..d6a465888117 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
##
## The following variables can be customized at build time. Use env or export to change at your wish
##
-## Example: env _microarchitecture=99 use_numa=n use_tracers=n use_pds=n makepkg -sc
+## Example: env _microarchitecture=98 use_numa=n use_tracers=n makepkg -sc
##
## Look inside 'choose-gcc-optimization.sh' to choose your microarchitecture
## Valid numbers between: 0 to 99
@@ -34,6 +34,11 @@ if [ -z ${use_tracers+x} ]; then
use_tracers=y
fi
+## GCC is the unique compiler supported
+if [ -z ${_compiler+x} ]; then
+ _compiler=gcc
+fi
+
# Compile ONLY used modules to VASTLY reduce the number of modules built
# and the build time.
#
@@ -114,6 +119,9 @@ prepare() {
patch -Np1 < "../$src"
done
+ # Applying configuration
+ cp -vf CONFIGS/xanmod/${_compiler}/config .config
+
# CONFIG_STACK_VALIDATION gives better stack traces. Also is enabled in all official kernel packages by Archlinux team
scripts/config --enable CONFIG_STACK_VALIDATION