summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoan Figueras2021-07-02 17:18:26 +0200
committerJoan Figueras2021-07-02 17:18:26 +0200
commit1206560f0692d213ff50224c3a6798c2fcd4ca7e (patch)
tree8d3bafad0de9311b5e82650bea147ee50107c887 /PKGBUILD
parent26cbd01f166cc778d30dc98b10f98fce56d6773a (diff)
downloadaur-1206560f0692d213ff50224c3a6798c2fcd4ca7e.tar.gz
Removed sphinx patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 9 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 333f0a745e92..3850daf9984e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -77,17 +77,17 @@ validpgpkeys=(
)
# Archlinux patches
-_commit="be7d4710850020de55bce930c83fa80347c02fc3"
-_patches=("sphinx-workaround.patch")
+_commit="ec9e9a4219fe221dec93fa16fddbe44a34933d8d"
+_patches=()
for _patch in ${_patches[@]}; do
- source+=("${_patch}::https://git.archlinux.org/svntogit/packages.git/plain/trunk/${_patch}?h=packages/linux&id=${_commit}")
+ #source+=("${_patch}::https://git.archlinux.org/svntogit/packages.git/plain/trunk/${_patch}?h=packages/linux&id=${_commit}")
+ source+=("${_patch}::https://raw.githubusercontent.com/archlinux/svntogit-packages/${_commit}/trunk/${_patch}")
done
sha256sums=('dcdf99e43e98330d925016985bfbc7b83c66d367b714b2de0cbbfcbf83d8ca43'
'SKIP'
'25d81d8f7211712ff3028a4089c3034a99b11904999e40e3992aeb36a972deb2'
- '51742dee57cd15bece152d6527f48af87cb7930f0f6a356d5282f778e7c35b39'
- '52fc0fcd806f34e774e36570b2a739dbdf337f7ff679b1c1139bee54d03301eb')
+ '51742dee57cd15bece152d6527f48af87cb7930f0f6a356d5282f778e7c35b39')
export KBUILD_BUILD_HOST=${KBUILD_BUILD_HOST:-archlinux}
export KBUILD_BUILD_USER=${KBUILD_BUILD_USER:-makepkg}
@@ -96,13 +96,6 @@ export KBUILD_BUILD_TIMESTAMP=${KBUILD_BUILD_TIMESTAMP:-$(date -Ru${SOURCE_DATE_
prepare() {
cd linux-${_major}
- # hacky work around for xz not getting extracted
- # https://bbs.archlinux.org/viewtopic.php?id=265115
- if [[ ! -f "$srcdir/patch-${pkgver}-rt${_rt}-xanmod${xanmod}" ]]; then
- unlink "$srcdir/patch-${pkgver}-rt${_rt}-xanmod${xanmod}.xz"
- xz -dc "$startdir/patch-${pkgver}-rt${_rt}-xanmod${xanmod}.xz" > "$srcdir/patch-${pkgver}-rt${_rt}-xanmod${xanmod}"
- fi
-
# Apply Xanmod patch
patch -Np1 -i ../patch-${pkgver}-rt${_rt}-xanmod${xanmod}
@@ -147,8 +140,8 @@ prepare() {
# Put the file "myconfig" at the package folder (this will take preference) or "${XDG_CONFIG_HOME}/linux-xanmod/myconfig"
# If we detect partial file with scripts/config commands, we execute as a script
# If not, it's a full config, will be replaced
- for _myconfig in "${startdir}/myconfig" "${XDG_CONFIG_HOME}/linux-xanmod/myconfig" ; do
- if [ -f "${_myconfig}" ]; then
+ for _myconfig in "${SRCDEST}/myconfig" "${HOME}/.config/linux-xanmod/myconfig" "${XDG_CONFIG_HOME}/linux-xanmod/myconfig" ; do
+ if [ -f "${_myconfig}" ] && [ "$(wc -l <"${_myconfig}")" -gt "0" ]; then
if grep -q 'scripts/config' "${_myconfig}"; then
# myconfig is a partial file. Executing as a script
msg2 "Applying myconfig..."
@@ -159,6 +152,7 @@ prepare() {
cp -f "${_myconfig}" .config
fi
echo
+ break
fi
done
@@ -182,7 +176,7 @@ prepare() {
[[ -z "$_makenconfig" ]] || make nconfig
# save configuration for later reuse
- cat .config > "${startdir}/config.last"
+ cat .config > "${SRCDEST}/config.last"
}
build() {