summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHouge Langley2021-04-11 10:18:22 +0800
committerHouge Langley2021-04-11 10:18:22 +0800
commit60cf1362052db88f30e69bab62719000f8180bcc (patch)
tree446db4b26c39ce9f55b14b3e61f4ac1de153d006 /PKGBUILD
parente278f6a1b6f297f777a72cc0032252e2d679cb65 (diff)
downloadaur-60cf1362052db88f30e69bab62719000f8180bcc.tar.gz
Update To v5.11.13
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 3 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a8373662a4b9..2cd1da587806 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -37,14 +37,6 @@ if [ -z ${use_tracers+x} ]; then
use_tracers=y
fi
-## Enable Cachy CPU scheduler by default https://github.com/xanmod/linux/blob/5.8/Documentation/scheduler/sched-Cachy.rst
-## Set variable "use_cachy" to: n to disable (stock Xanmod)
-## y to enable
-## Cachy 已经退出历史舞台,后来作者也将这个算法转移到 CaCule,个人也比较推荐这个,响应速度更快
-if [ -z ${use_cachy+x} ]; then
- use_cachy=n
-fi
-
## Enable CONFIG_USER_NS_UNPRIVILEGED flag https://aur.archlinux.org/cgit/aur.git/tree/0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch?h=linux-ck
## Set variable "use_ns" to: n to disable (stock Xanmod)
## y to enable (stock Archlinux)
@@ -71,7 +63,7 @@ _makenconfig=y
### IMPORTANT: Do no edit below this line unless you know what you're doing
pkgbase=linux-xanmod-uksm
-pkgver=5.11.12
+pkgver=5.11.13
_major=5.11
_branch=5.x
xanmod=1
@@ -88,7 +80,7 @@ options=('!strip')
_srcname="linux-${pkgver}-xanmod${xanmod}"
source=("https://cdn.kernel.org/pub/linux/kernel/v${_branch}/linux-${_major}.tar."{xz,sign}
- "https://github.com/HougeLangley/Xanmod-UKSM/releases/download/Fix/patch-5.11.12-xanmod1"
+ "https://github.com/HougeLangley/Xanmod-UKSM/releases/download/Fix/patch-5.11.13-xanmod1"
choose-gcc-optimization.sh
'sphinx-workaround.patch'
'0002-UKSM.patch')
@@ -110,13 +102,6 @@ sha256sums=('04f07b54f0d40adfab02ee6cbd2a942c96728d87c1ef9e120d0cb9ba3fe067b4'
'74339b8ad0ad99f08606c5de0dd3c38f502e29e5c6a78d6efbe656662edb8d73'
'f00a84fd382d63cd0d47d6fd8ef6c8608b1c83ff9d6dbdd32cb985898afbbf58')
-# If use_cachy=y then download cachy patch
-if [ "$use_cachy" = "y" ]; then
- echo "Cachy branch is not ready yet..." && exit 1
- source+=("https://github.com/xanmod/linux/releases/download/${pkgver}-xanmod${xanmod}-cachy/patch-${pkgver}-xanmod${xanmod}-cachy.xz")
- sha256sums+=('c35685c5d706a683fc0b02cf11fd40db52becae9205bf0d71f6a4a901d836d69')
-fi
-
export KBUILD_BUILD_HOST=${KBUILD_BUILD_HOST:-archlinux}
export KBUILD_BUILD_USER=${KBUILD_BUILD_USER:-makepkg}
export KBUILD_BUILD_TIMESTAMP=${KBUILD_BUILD_TIMESTAMP:-$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH})}
@@ -125,11 +110,7 @@ prepare() {
cd linux-${_major}
# Apply Xanmod patch
- if [ "$use_cachy" = "y" ]; then
- patch -Np1 -i ../patch-${pkgver}-xanmod${xanmod}-cachy
- else
- patch -Np1 -i ../patch-${pkgver}-xanmod${xanmod}
- fi
+ patch -Np1 -i ../patch-${pkgver}-xanmod${xanmod}
msg2 "Setting version..."
scripts/setlocalversion --save-scmversion
@@ -165,11 +146,6 @@ prepare() {
scripts/config --disable CONFIG_NUMA
fi
- if [ "$use_cachy" = "y" ]; then
- msg2 "Enabling Cachy CPU scheduler by default..."
- scripts/config --enable CONFIG_CACHY_SCHED
- fi
-
if [ "$use_ns" = "n" ]; then
msg2 "Disabling CONFIG_USER_NS_UNPRIVILEGED"
scripts/config --disable CONFIG_USER_NS_UNPRIVILEGED