summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatt Parnell2016-12-18 17:37:39 -0600
committerMatt Parnell2016-12-18 17:37:39 -0600
commit6102b790c6cc396d654921ca4150a6a0d7394da6 (patch)
treecf184e44524c96b15739b2a690ca7638f38f4168 /PKGBUILD
parent833ec7a9064481c8b5a95a08884ccef846ef39fc (diff)
downloadaur-6102b790c6cc396d654921ca4150a6a0d7394da6.tar.gz
4.9 with a couple quick sed hacks to make it build properly
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 16 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9b34b25fc854..b40a51559b81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Original PKGBUILD Contributor: Patrick Bartels <p4ddy.b@gmail.com>
# Thanks to Bregol
pkgname="linux-zen-git"
-pkgver=4.8.3+618265+g51c248f
+pkgver=4.9.0+635574+g46451c63787b
pkgdesc="Featureful kernel including various new features, code and optimizations to better suit desktops"
url="https://github.com/damentz/zen-kernel"
license=("GPL2")
@@ -16,7 +16,7 @@ pkgrel=1
options=("!strip")
source=("linux-zen.conf"
"linux-zen.preset"
- 'git://github.com/damentz/zen-kernel.git#branch=4.8/master')
+ 'git://github.com/damentz/zen-kernel.git#branch=4.9/master')
sha256sums=('6373073ad943e068478ef1373be4eb2a7e473da8743d946f1f50cd364685ab87'
'18fe6b2664a9a740544c4cb990efe5ec933d6e64caf9e5d0a6ced92af0027c2d'
'SKIP')
@@ -36,6 +36,20 @@ prepare() {
if [ $_CORES -lt 1 ]; then
_CORES=2
fi
+
+ git reset --hard
+
+ _BADLINE=$(sed '656!d' Makefile)
+ if [ "$_BADLINE" != "endif" ]; then
+ msg "Applying quick fix for missing endif"
+ sed -i '656iendif' Makefile # quick fix for missing endif in current 4.9 branch
+ fi
+
+ _MISSINGHEADERS=$(sed '20!d' block/bfq-cgroup.c)
+ if [ "$_MISSINGHEADERS" != "#include \"blk.h\"" ]; then
+ msg "Applying quick fix for a couple missing headers for BFQ"
+ sed -i "20i#include \"blk.h\"\n#include \"blk-wbt.h\"\n" block/bfq-cgroup.c
+ fi
}
pkgver() {