summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoralealexpro1002021-08-15 13:45:39 +0800
committeralealexpro1002021-08-15 13:45:39 +0800
commit0753ee8bda44c16d9029e74755b10c0a65d14956 (patch)
treec35748a4ae5ddcc46c7e38f82dba9bdb5ee780dc /PKGBUILD
parent2a06a9e5a8b5d32272fc8b1c8f2020b685d6c9fb (diff)
downloadaur-0753ee8bda44c16d9029e74755b10c0a65d14956.tar.gz
Update to 0.5.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ba1987fc9f0f..e284adb2037f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=linux_install-git
_reponame=linux_install
-pkgver=0.5.2.r0.gad2e1b0
+pkgver=0.5.3.r0.g62bf965
pkgrel=1
pkgdesc="Install various distros from Linux to any architecture."
arch=('any')
@@ -11,8 +11,7 @@ license=('GPL3')
depends=('coreutils' 'util-linux' 'bash' 'wget' 'tar' 'zstd')
makedepends=('git')
optdepends=('debootstrap: debian support'
- 'qemu-user-static: foreign architectures support'
- 'squashfs-tools: live installer build support')
+ 'qemu-user-static: foreign architectures support')
source=("git+https://github.com/alealexpro100/linux_install.git")
md5sums=('SKIP')
@@ -29,15 +28,18 @@ prepare() {
package() {
cd "$srcdir/$_reponame" || exit 1
- rm -rf "_config.yml" "bin/debootstrap-debian" "custom" "tests"
+ rm -rf "_config.yml" "bin/debootstrap-debian" "custom" "tests" "bin/make_images"
for file in TODO README.md CHANGES.md; do
install -Dm644 "$file" "$pkgdir/usr/share/doc/$pkgname/$file"
rm -rf "$file"
done
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
rm -rf LICENSE
+ install -m644 -d "$pkgdir/usr/share/$pkgname/auto_configs"
+ cp -r auto_configs/* "$pkgdir/usr/share/$pkgname/auto_configs"
+ rm -rf auto_configs
install -m755 -d "$pkgdir/usr/lib/$pkgname"
- cp -r * "$pkgdir/usr/lib/$pkgname"
+ cp -r ./* "$pkgdir/usr/lib/$pkgname"
for file in install_sys profile_gen; do
install -Dm755 "${srcdir}/$file" "$pkgdir/usr/bin/$file"
done