summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-07-02 11:30:24 +0100
committerGonçalo Camelo Neves Pereira2018-07-02 11:30:24 +0100
commit61c48342399eb42d4d4164b52b3396e8f60c2912 (patch)
treed18bdc32661350cc93d2a8fa7b50656f9a5e4933 /PKGBUILD
parentb038d741193b8414dc762002e91208d3e4865c1f (diff)
downloadaur-61c48342399eb42d4d4164b52b3396e8f60c2912.tar.gz
Solve tcl dependency issue
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bb2c2029e758..d3653919e07b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc="It can interpret G-code and simulate a CNC machine (formerly EMC2)."
arch=('i686' 'x86_64')
license=('GPL2')
url="http://linuxcnc.org/"
-depends=('bc' 'bwidget' 'tcl' 'tk' 'xorg-server' 'python2-imaging' 'tkimg' 'python2-gtkglext' 'tclx' 'boost' 'boost-libs')
+depends=('bc' 'bwidget' 'tcl' 'tk' 'xorg-server' 'python2-imaging' 'tkimg' 'python2-gtkglext' 'tclx' 'boost' 'boost-libs' 'libtirpc')
install=$pkgname.install
_gitname='linuxcnc'
source=($_gitname::"git://github.com/LinuxCNC/linuxcnc.git#tag=v$pkgver" 'boost.patch' 'image-to-gcode.patch' 'linuxcnc-sim.sh')
@@ -38,6 +38,8 @@ build () {
# cd $srcdir/$pkgname-$pkgver
# patch -Np1 < $srcdir/jepler-modsilent.patch
# cd $srcdir/$pkgname-$pkgver/src
+ CPPFLAGS+=" -I/usr/include/tirpc/"
+ LDFLAGS+=" -ltirpc"
./autogen.sh
./configure --with-realtime=uspace --without-libmodbus --prefix=/usr --with-python=/usr/bin/python2.7 --enable-non-distributable=yes
make