summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJulia DeMille2021-12-20 16:45:41 -0600
committerJulia DeMille2021-12-20 16:45:41 -0600
commit298f80478409b1be87a3f3d08cd3bebd0acb27aa (patch)
tree419eb94dfbb33c9b37e1b40102cbe775f0a7346c /PKGBUILD
parent01f68ba3bab66229a1ff688e30455758dff7e453 (diff)
downloadaur-298f80478409b1be87a3f3d08cd3bebd0acb27aa.tar.gz
Changed to be release instead of Git, will make linvst-git package.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 5 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f88a28633177..070e15208507 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Julia DeMille <me@jdemille.com>
# Contributor: David <ottodavid@gmx.net>
pkgname=linvst
-pkgver=4.7.r11.141e405
+pkgver=4.7
pkgrel=1
license=('GPL3')
pkgdesc="Windows VST2 wrapper that allows them to be used as Linux VST2s in compatible DAWs using Wine."
@@ -9,20 +9,15 @@ arch=('x86_64')
url="https://github.com/osxmidi/LinVst"
depends=('wine')
makedepends=('git')
-source=('linvst::git+https://github.com/osxmidi/LinVst.git')
-sha256sums=('SKIP')
-
-pkgver() {
- cd "${pkgname}"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
+source=('linvst-4.7.tar.gz::https://github.com/osxmidi/LinVst/archive/refs/tags/4.7.tar.gz')
+sha256sums=('96cf075eebb9db4d23f6fe7327b70496320f3d751e5ec24b7ffa3e29c750c8d1')
build() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/LinVst-${pkgver}"
make DESTDIR="${pkgdir}" all
}
package() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/LinVst-${pkgver}"
make DESTDIR="${pkgdir}" VST_DIR="${pkgdir}/usr/lib/vst/" install
}