summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorusrmusicman2019-10-23 15:43:36 -0400
committerusrmusicman2019-10-23 15:43:36 -0400
commit4ba5278ec09e759dbfb05db7e1b4ee01ca43a629 (patch)
treebf92073adf59a80f1229d38b234dff7cad513cad /PKGBUILD
parent4a9e9d25aee10179e68e9a582fdfd1b37449f101 (diff)
downloadaur-4ba5278ec09e759dbfb05db7e1b4ee01ca43a629.tar.gz
Update PKGBUILD and remove w2lvst2 script
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 13 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d38c2bd78e3a..ec5261a7b1f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,26 @@
+# Maintainer Alex Mcmillan <linuxguy93@gmail.com>
+
pkgname=linvst2
pkgver=2.7.2
-pkgver_w2lvst2=2.4
-pkgrel=1
+pkgrel=2
pkgdesc="enables Windows vst's to be used as Linux vst's in Linux vst capable DAW's"
arch=('x86_64')
url="https://github.com/osxmidi/LinVst"
depends=('wine' 'python>=3.7')
conflicts=('linvst' 'linvst-stable')
replaces=('linvst' 'linvst-stable')
-source=("https://github.com/osxmidi/LinVst/releases/download/2.7/LinVst-64bit-32bit_${pkgver}.deb"
- "https://github.com/usrmusicman/ArchStudioUtils/archive/${pkgver_w2lvst2}.zip")
+source=("https://github.com/osxmidi/LinVst/releases/download/2.7/LinVst-${pkgver}-Debian-Stretch.zip"
+ "git+https://github.com/usrmusicman/ArchStudioUtils.git")
sha256sums=('SKIP'
'SKIP')
package() {
- cd "${srcdir}"
-
- ## Unpack Contents
- tar -xzf data.tar.gz
-
- ## Remove GUI Linker Programss
- rm $srcdir/usr/bin/linvstconvert*
-
- ## Copy Files
- cp -r $srcdir/usr $pkgdir/usr
-
- ## Install CLI Linker Program (Python3)
- install -Dm755 $srcdir/ArchStudioUtils-$pkgver/w2lvst2 $pkgdir/usr/bin/w2lvst2
+ cd "${srcdir}/LinVst-${pkgver}-Debian-Stretch/embedded/"
+ for file in *.so; do
+ install -Dm755 $file $pkgdir/usr/bin/$file
+ done
+ for file in *.exe; do
+ install -Dm755 $file $pkgdir/usr/bin/$file
+ done
+ install -Dm755 $srcdir/ArchStudioUtils/w2lvst2 $pkgdir/usr/bin/w2lvst2
}