summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorusrmusicman2019-08-02 07:57:34 -0400
committerusrmusicman2019-08-02 07:57:34 -0400
commit7a394b6d53e3bbb279d9d665797e575abef09976 (patch)
tree47a068d27b01150f008adc6068c435e90f203296 /PKGBUILD
downloadaur-7a394b6d53e3bbb279d9d665797e575abef09976.tar.gz
Add linvst2 as a stable variant of linvst package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4070466c134f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=linvst2
+pkgver=2.6.0
+pkgrel=1
+pkgdesc="enables Windows vst's to be used as Linux vst's in Linux vst capable DAW's"
+arch=('x86_64')
+url="https://github.com/osxmidi/LinVst"
+depends=('wine' 'python>=3.7')
+conflicts=('linvst' 'linvst-stable')
+replaces=('linvst' 'linvst-stable')
+source=("https://github.com/osxmidi/LinVst/releases/download/2.6/LinVst-64bit-32bit_${pkgver}.deb"
+ "w2lvst2")
+sha256sums=('SKIP'
+ 'SKIP')
+
+package() {
+ cd "${srcdir}"
+
+ ## Unpack Contents
+ tar -xzf data.tar.gz
+
+ ## Remove GUI Linker Programss
+ rm $srcdir/usr/bin/linvstconvert*
+
+ ## Copy Files
+ cp -r $srcdir/usr $pkgdir/usr
+
+ ## Install CLI Linker Program (Python3)
+ install -Dm755 w2lvst2 $pkgdir/usr/bin/w2lvst2
+}