summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSergey Kasmy2020-02-18 15:25:06 +0100
committerSergey Kasmy2020-02-18 15:25:06 +0100
commit28f4ce985426852ac8a13e55faa42d8d155bb67e (patch)
tree7593413217b9129b922822512c3cce1655390895 /PKGBUILD
parent28ca3c6ded3066e8897418141ca6b4b12d54bcc2 (diff)
downloadaur-28f4ce985426852ac8a13e55faa42d8d155bb67e.tar.gz
Rename package to liquidctl
Follow Arch naming guidelines more closely
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 15d9070793da..fdcd9efdfe04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
-pkgname=('python-liquidctl')
-_module='liquidctl'
+#Maintainer: Sergey Kasmy <SleeplessSloth79@gmail.com>
+
+pkgname=liquidctl
pkgver='1.3.0'
pkgrel=1
pkgdesc="Cross-platform tool and drivers for liquid coolers and other devices"
@@ -12,7 +13,7 @@ source=("https://files.pythonhosted.org/packages/source/l/liquidctl/liquidctl-${
sha256sums=('ce0483b0a7f9cf2618cb30bdf3ff4195e20d9df6c615f69afe127f54956e42ce')
build() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
export DIST_NAME="$(source /etc/os-release && echo $PRETTY_NAME)"
export DIST_PACKAGE="$pkgname $pkgver-$pkgrel"
python setup.py build
@@ -20,7 +21,7 @@ build() {
package() {
depends+=()
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
install -Dm644 liquidctl.8 "${pkgdir}/usr/share/man/man8/liquidctl.8"
}