summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdam Rutkowski2019-10-03 08:56:14 +0200
committerGitHub2019-10-03 08:56:14 +0200
commit59f1e0a0e06f8d3958a07e4ba35ad119a21d19b8 (patch)
tree31b31a287c10f7c9fd573a29e77eb689bc4236e1 /PKGBUILD
parent26cbbd2084236c3e5079c1e16aa8e6fe6490aa1f (diff)
parentd4c52e4966742b51944cbf6c32c19ee1d25a9887 (diff)
downloadaur-59f1e0a0e06f8d3958a07e4ba35ad119a21d19b8.tar.gz
Merge pull request #1 from jonasmalacofilho/update-to-1.2.0
Update to 1.2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e84b6182dd7..7320892bb1a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,20 @@
pkgname=('python-liquidctl')
_module='liquidctl'
-pkgver='1.1.0'
+pkgver='1.2.0'
pkgrel=1
pkgdesc="Cross-platform tool and drivers for liquid coolers and other devices"
url="https://github.com/jonasmalacofilho/liquidctl"
-depends=('python' 'libusb')
-makedepends=('python-setuptools')
+depends=('python' 'python-setuptools' 'python-pyusb' 'python-hidapi' 'python-docopt' 'python-appdirs')
+makedepends=()
license=('GPL3')
arch=('any')
source=("https://files.pythonhosted.org/packages/source/l/liquidctl/liquidctl-${pkgver}.tar.gz")
-md5sums=('1fcf5a49e73c3799f49fb6a977b6cde9')
+sha256sums=('ad8c03c0695620fedaec11e7a8286bb5d4da18ba0c71e55888bfa06f8f7d7529')
build() {
cd "${srcdir}/${_module}-${pkgver}"
+ export DIST_NAME="$(source /etc/os-release && echo $PRETTY_NAME)"
+ export DIST_PACKAGE="$pkgname $pkgver-$pkgrel"
python setup.py build
}