summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonas Malaco2020-07-30 23:29:59 -0300
committerJonas Malaco2020-07-30 23:34:29 -0300
commitac39e66a23e881c2ab4abe201095556c4f89dbba (patch)
tree239287e8b22259fc1e6f23d3c50afa9ac432ca77 /PKGBUILD
parentd3b77d0a9723e620e5af440984717cea54811248 (diff)
downloadaur-ac39e66a23e881c2ab4abe201095556c4f89dbba.tar.gz
Use constant DIST_NAME for simplicity and correctness
Taking DIST_NAME from os-release PRETTY_NAME is preferred for official distribution packages, but it is less important in the AUR. In fact, in the AUR, the "distribution" this package is part of is the AUR itself. Additionally, some ArchLinux derivatives that don't use systemd may not have /etc/os-release linked to /usr/lib/os-release, and handling this would add unnecessary complexity. Finally, some ArchLinux derivatives don't override /usr/lib/os-release PRETTY_NAME. A constant "Arch User Repository" value more clearly indicates that nothing is know about the system where liquidctl is actually running, only that it was built using the AUR PKGBUILD.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9ddb440649b1..6d15fb0b7d80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Fabio Loli
# Contributor: Sergey Kasmy
pkgname=liquidctl-git
-pkgver=1.3.3.r358.dd4b583
+pkgver=1.3.3.r359.6951f41
pkgrel=1
pkgdesc='Cross-platform tool and drivers for liquid coolers and other devices'
arch=('any')
@@ -22,10 +22,9 @@ pkgver() {
}
build() {
- # customize the output of liquidctl --version
- # (note: in ArchLinux /etc/os-release is a symlink managed by systemd,
- # see: https://bbs.archlinux.org/viewtopic.php?id=251724)
- export DIST_NAME="$(source /etc/os-release && echo $PRETTY_NAME)"
+ # customize the output of liquidctl --version; official distribution
+ # packages should generally set DIST_NAME to os-release PRETTY_NAME)
+ export DIST_NAME="Arch User Repository"
export DIST_PACKAGE="$pkgname $pkgver-$pkgrel"
cd "$srcdir/$pkgname"