summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJan Neumann2017-11-10 19:28:20 +0100
committerJan Neumann2017-11-10 19:28:20 +0100
commit381338e54e61b8b4be137ab3ce1e5ad526e25084 (patch)
tree989cd873b6863bf2210c793836a085885f06de47 /PKGBUILD
downloadaur-381338e54e61b8b4be137ab3ce1e5ad526e25084.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ecbbdae80f57
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+
+# Maintainer: Jan Neumann <neum dot ja at gmail dot com>
+
+
+pkgname=liquidshell-git
+pkgver=r64.9cc1429
+pkgrel=1
+pkgdesc='liquidshell is an alternative to plasmashell'
+arch=('x86_64')
+url='https://cgit.kde.org/liquidshell.git/'
+license=('GPL3')
+depends=('networkmanager-qt' 'bluez-qt' 'kcmutils')
+makedepends=('cmake' 'extra-cmake-modules' 'git')
+source=("${pkgname}-${pkgver}::git+git://anongit.kde.org/liquidshell.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ mkdir build && cd build
+ cmake ..
+
+ make
+
+ }
+
+package() {
+ install -Dm755 ${srcdir}/${pkgname}-${pkgver}/build/liquidshell ${pkgdir}/usr/bin/liquidshell
+}