summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJan Neumann2017-11-11 14:42:39 +0100
committerJan Neumann2017-11-11 14:42:39 +0100
commit6516693cd6a9f98dff2e170268164d5aa3e204a6 (patch)
tree71f1a992b1d1f8ecb5cbf7d55262019b15fed9d9 /PKGBUILD
parentfcac45064c4547a6e6b19a0b8f008ab5b6208318 (diff)
downloadaur-6516693cd6a9f98dff2e170268164d5aa3e204a6.tar.gz
fix
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 83df7e436a1a..f61e99927096 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,8 @@
pkgname=liquidshell-git
-pkgver=r64.9cc1429
+_gitname=liquidshell
+pkgver=r65.87b14e3
pkgrel=1
pkgdesc='liquidshell is an alternative to plasmashell'
arch=('x86_64')
@@ -11,19 +12,19 @@ url='https://cgit.kde.org/liquidshell.git/'
license=('GPL3')
depends=('networkmanager-qt' 'bluez-qt' 'kcmutils' 'knewstuff')
makedepends=('cmake' 'extra-cmake-modules' 'git')
-source=("${pkgname}-${pkgver}::git+git://anongit.kde.org/liquidshell.git")
+source=("git+git://anongit.kde.org/liquidshell.git")
sha256sums=('SKIP')
pkgver() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd ${srcdir}/${_gitname}
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd ${srcdir}/${_gitname}
mkdir build && cd build
cmake ..
@@ -33,6 +34,6 @@ build() {
package() {
- install -Dm755 ${srcdir}/${pkgname}-${pkgver}/build/liquidshell ${pkgdir}/usr/bin/liquidshell
+ install -Dm755 ${srcdir}/${_gitname}/build/liquidshell ${pkgdir}/usr/bin/liquidshell
}